Dome light/reading light problems - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion (2011-2016) 6.7 Electronics Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-25-2016, 09:27 AM Thread Starter
Member
 
Join Date: Jun 2007
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Dome light/reading light problems

Hey guys I have a question to ask for a friend of mine. He has been doing some work on his 2015 F250 crew cab XL lately and is having trouble with some of his lights in the cab. Specifically the passenger side reading lights in both front and back.

He had replaced the head unit and ran new cabling to add a couple amps and a sub. After putting things back together he noticed that the underhood light wasn't working as well as the dome lights. Found that a fuse was blown. He replaced it and everything started working again until he would turn on one of the passenger side reading lights.

He had replaced the bulbs with led replacements from recon as well in case that matters. Is their some sort of relay that is not working that would happen to seperate out just those passenger side reading lights?

I had him check with a bolt meter and he said that he has no voltage to the sockets on the passenger side while he has 12+VDC to the drivers side. Are these light physically wired differently from side to side?

What can he check next? Thanks for your help!
fordmustangfan67 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-26-2016, 06:49 AM Thread Starter
Member
 
Join Date: Jun 2007
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anyone have any suggestions as to what to try or what to look for? Pinched wire somewhere maybe? Just not sure why it would be seemingly isolated to the passenger reading lights unless somehow the are wired seperately.
fordmustangfan67 is offline  
post #3 of 3 Old 04-26-2016, 07:40 AM Thread Starter
Member
 
Join Date: Jun 2007
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It is fuse #4 in the passenger side fuse panel that is blowing. It's a 10A fuse.
fordmustangfan67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome