HID Install Help! - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion (2011-2016) 6.7 Electronics Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-15-2016, 03:18 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
HID Install Help!

I recently purchased a 2015 F350. I bought Kensun HID headlights and fog lights. I installed the Headlights with no issue and they look great.

My problem lies with the fog lights. They are the Kensun 35w 6000k fog light kit. I went to install them and i am not getting them to light up at all. i have reversed the polarity on the kit, along with changing the fog light fuse from a 15amp to a 20amp (recommended by Kensun) . I have even returned my kit to Kensun and had them send me a brand new kit.

I have no idea what else to do. Should i purchase a relay harness for the fog light kit or find another set that is compatible?

Last edited by FFVHarris; 04-15-2016 at 03:21 AM.
FFVHarris is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-18-2016, 05:27 AM
Powerstroke.org Fanatic
 
a2designs's Avatar
 
Join Date: Nov 2012
Posts: 129
Thanks: 1
Thanked 7 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by FFVHarris View Post
I recently purchased a 2015 F350. I bought Kensun HID headlights and fog lights. I installed the Headlights with no issue and they look great.

My problem lies with the fog lights. They are the Kensun 35w 6000k fog light kit. I went to install them and i am not getting them to light up at all. i have reversed the polarity on the kit, along with changing the fog light fuse from a 15amp to a 20amp (recommended by Kensun) . I have even returned my kit to Kensun and had them send me a brand new kit.

I have no idea what else to do. Should i purchase a relay harness for the fog light kit or find another set that is compatible?
I am not familiar with that kit. I have installed HIDs before and know that you need to have a solid ground for them to work. I would check that first. It should be a plug and play to the factory harness. Everything else is basically wire management and solid connections. Make sure to hit everything with Dielectric grease too.

'16 F-350 CCLB Platinum
a2designs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome