HAS ANYONE SEEN THIS BEFORE - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-14-2019, 02:43 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
HAS ANYONE SEEN THIS BEFORE

Bought this 08 6.4 with 103k original miles and a fresh rebuild with only 3500 miles since and pulling our trailer it just shut down like the key was turned off. Found out later this happened and Joe's Engine that did the rebuild is trying to get an additional $3500 to do the replacement under the warranty. Is this common, everyone I have spoke with says they have never heard of a crank breaking, I was doing 60-65 2k rpm on a smooth straight section of the 5 fwy
Attached Thumbnails
Click image for larger version

Name:	POWERSTROKE.jpg
Views:	46
Size:	144.2 KB
ID:	725215  
Tom Zalabak is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-14-2019, 03:07 PM
,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 28,452
Thanks: 2,198
Thanked 1,824 Times in 1,768 Posts
Mentioned: 705 Post(s)
Quoted: 3962 Post(s)
Feedback Score: 0 reviews
you sure it did not hydrolock first ?

this Joes?
JOE'S ENGINES | 5200 S. Santa Fe Ave. | Vernon | CA | 90058

6.0 flush pdf
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by ZMANN; 11-14-2019 at 03:12 PM.
ZMANN is online now  
post #3 of 4 Old 11-14-2019, 08:59 PM
Compression Ignition Addict
 
RandomForumGuy's Avatar
 
Join Date: Jan 2016
Posts: 1,175
Thanks: 2
Thanked 89 Times in 80 Posts
Mentioned: 8 Post(s)
Quoted: 214 Post(s)
Garage
Feedback Score: 0 reviews
Under stock power i have never seen a crank fail. If you bought the engine from them and its under warranty, why are they wanting to charge you?
RandomForumGuy is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 11-14-2019, 11:43 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes Joe's in Vernon, company truck was taken there for the motor to be rebuilt then back because of white smoke when started hot so they said they redid the heads and then less then 350 miles after getting it back the second time it blew up. Truck was running great, was on the 5 Freeway headed North east of Fresno on a smooth straight run following a Stillen Motorsports 18 wheeler for around 20 miles at 60-65 mph truck was running fine, wasn't pushing it, then as if I bumped the key off, nothing, no power steering or brakes, had to coast to the shoulder and luckily found some room off the road then the fun of trying to stop with a 34+ Trailer and no power brakes at 1:00 am.

As far as the charges they are trying to collect for new injectors, new oil cooler and $1000 labor complaining about having to cover the core damage cost and other costs.
Tom Zalabak is offline  
Sponsored Links
Advertisement
 
Reply

Tags
6.4 , cause crank to break , crank breaking

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome