Acceleration - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-20-2019, 07:18 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Acceleration

6.4 2008 , when in park rpm goes up and in neutral. When on drive it does same. Today I was goin around 60 and pressed pedal to go faster and it didn’t respond. I pressed all way down and nothing. Pulled over turned it off then on and worked. But rpm issue has been like this for 4 days now
Arodz19 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-20-2019, 09:42 AM
Member
 
Join Date: Jan 2019
Posts: 85
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 30 Post(s)
Feedback Score: 0 reviews
Could it be the pedal? Or possibly a chafed wire somewhere....
nsfr1206 is offline  
post #3 of 3 Old 07-20-2019, 01:04 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by nsfr1206 View Post
Could it be the pedal? Or possibly a chafed wire somewhere....
I don’t know what it’s is. It’s my first diesel. Bothers me
Arodz19 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome