6.4 no start after engine rebuild - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-19-2019, 04:39 PM Thread Starter
Member
 
Join Date: Dec 2018
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
6.4 no start after engine rebuild

had to buy a reman longblock engine. did the swap and everything went well. primed up the fuel and oil but the truck will not start from the cab via the key cranking. I have to turn the key on and go out to the starter wire by the passenger battery, jumping power from the batter to the starter and it will crank for 5-10 seconds before firing off, then will run fine and shut off again via the key from the cab. anyone have any thoughts or ever have this issue? I have the dpf and egr deleted but no tuner yet so I do have a bunch of codes due to that but still don't know or think its enough to not let start from the cab! please help!
greygoose08 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-19-2019, 05:36 PM
Your Local Windex Brewer

 
CrazyS0b's Avatar
 
Join Date: Aug 2014
Location: Minneapolis
Posts: 5,928
Thanks: 275
Thanked 476 Times in 450 Posts
Mentioned: 63 Post(s)
Quoted: 603 Post(s)
Feedback Score: 0 reviews
If its deleted you will need a tuner for the truck to run... The pcm will lock you out.

2015 F350 SRW CCSB Lariat - Stock, for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 F350 SRW CCSB FX4 - Airaid CAI, FloPro 5" straight pipe, Egr delete with BD intake elbow, SCT X4 with tunes from Tyrant Diesel, Monitored by CTS, Fox 2.0s. - SOLD
-Matthew


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CrazyS0b is offline  
post #3 of 4 Old 01-28-2019, 02:07 PM Thread Starter
Member
 
Join Date: Dec 2018
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
ok well I put back in my other ecm which has a single tune on the ecm itself and the truck will fire up now. I had it firing normal (in park) but now I can only get it to fire and crank when the trucks in neutral???? I took it out for a little drive to test everthing out, and noticed my speedo, coolant temp not working, and lack of power. so I thought to put in my other TCM thinking for some reason that maybe just maybe the speedo was tied into the tcm. well it wasn't, actually lost communication with the tcm and had to ohm out the whole harness and check every fuse over before finally getting power back to the tcm, but now it only cranks and fires in neutral. does anyone have an idea on this issue?? any help greatly appreciated before I have to take it to the dealer and get taken for there
greygoose08 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 12-05-2019, 08:35 PM
Powerstroke.org Rookie
 
Join Date: Dec 2019
Posts: 8
Thanks: 11
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The Stock Tune looks for EGR & DPF signals before it will start the motor.

One has to re-flash the ecm and state that the emissions are gone.

If you leave the base tune in place at this point in time, the check engine light comes on after a short while of driving with a missing EGR code error. With the Mini Maxx you can clear this code while driving.

To get the code to go away, you must use one of the H&S specific tunes that then ignore the EGR circuit altogether.

The different tuners will have have slightly different options.

Last edited by sbc97281; 12-22-2019 at 02:21 PM.
sbc97281 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome