Rpm issues - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 08-12-2019, 07:13 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Rpm issues

Replaced accel pedal and truck still has high rpm on park and rest. When press brakes it comes down. People any responses will work. Oh and I can’t erase the pedal code. Keeps coming back
Arodz19 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-12-2019, 08:09 PM
Member
 
Join Date: Jan 2019
Posts: 68
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 1 Post(s)
Quoted: 15 Post(s)
Feedback Score: 0 reviews
The 6.4 does have a high idle function. Designed for colder weather to idle and warm up faster. Typically reads the outside temp to tell when to kick to high idle. Some people have wired it to high idle anytime so that may be your case? You can cancel it by stepping on brake or putting in gear like you said but after a couple seconds it will start to raise the rpms again topping out at 1100 rpms. Maybe a faulty ambient temp sensor? Other than that, check your voltage going towards battery from alternator. If the voltage is lower that 12.5/13 it will kick into a higher idle to attempt to compensate. Could be symptoms of a failing alternator, batteries, or the feed cables from those
colesalisbury01 is offline  
post #3 of 4 Old 08-24-2019, 07:51 AM
Member
 
Join Date: Nov 2016
Location: Dyer
Posts: 81
Thanks: 33
Thanked 2 Times in 2 Posts
Mentioned: 1 Post(s)
Quoted: 14 Post(s)
Feedback Score: 0 reviews
There are a few pages about this in the owners manual that I read a few days ago. Actually it was a smaller separate book. Had my new to me truck about a year and just ready through things


Sent from my iPhone using Tapatalk
isellrareunicorndna is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 08-24-2019, 06:05 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I figured it out. Well not me but it wasn’t pedal after all. It was the computer. 150 used computer 150 to program
Arodz19 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome