2010 f350 6.4 electrical craziness in Hawaii - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 2Likes
  • 2 Post By JustinOOO9
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-20-2019, 02:13 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2010 f350 6.4 electrical craziness in Hawaii

Trying to help a friend diagnose an electrical issue on his truck .. originally he was getting code U0101 . We checked the connector at the trans and was loose . This code hasn't shown up again yet . We took it for a test drive and after driving for around 4 miles all kind s of lights were coming on and off , the gauges were bouncing around or completely off , loss of power and it sounded like a jet engine out the exhaust. after coming to a stop the truck locked him out and wouldn't restart. After dc the battery for about 10 minutes the truck could restart again but got code P0100.. The reader said it lost connection from PCM and ECM . When I looked up the code it says it is an issue with the MAF sensor .. Has anyone had any issues with this ??Any ideas? please help
westb68 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-20-2019, 02:58 PM
Serving Our Country!

 
JustinOOO9's Avatar
 
Join Date: Nov 2012
Posts: 7,703
Thanks: 371
Thanked 647 Times in 598 Posts
Mentioned: 42 Post(s)
Quoted: 1572 Post(s)
Garage
Feedback Score: 3 reviews
with the salty air I would start with basics:

weak/dying batteries make these trucks seem like they are possessed. Remove them and get each one tested when not connected to anything.

Check/clean all grounds battery cables

check and apply a tiny bit of di electric grease to all wire connections clips

check all fuses for corrosion and replace as necessary (just the tiniest amount of dielectric grease will help future corrosion

Check alternator and associated connections

**again I cannot stress how a single or pair of weak/dying batteries will just wreck your life. The powerstrokes need strong steady power.


My bet is bad battery(s) and or multiple corroded grounds/power connections
partyman97_3 and westb68 like this.

-99 F250, 4X4, 6.0 trans cooler, 08 mirrors, 05 grill, AIS Intake, lvl kit, JW Vbody, cncfab hpop lines, WW2.

04 Excursion Modified, 04 F350 Modified, 06 F350 Modified

Interested in learning something new?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Justin
JustinOOO9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome