ANYONE HELP PLEASE.....Wont go over 2500rpm.... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-10-2011, 12:37 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation ANYONE HELP PLEASE.....Wont go over 2500rpm....

when you first start it when it is cold it runs great. Drive about 3miles and i lose power.....i have all the low end power but no top end....when you go it starts bogging down at 2200 and wont go over 2500 when you got it to the floor....if you hold it to the floor it will blow a little bit of a white/blue smoke. the codes i found in it are as follows.....P0403,P0404,P0405,P0488,P0670,P0683,P1 102,P2262. So i cleared them and did a KOER test and got only these 3 codes. P0670,P1102,P1408. i need help i need to get this thing running i cant run my business without this truck......ANY ANSWERS
pimpingtp98 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-10-2011, 01:07 PM
Powerstroke Techie

 
m-chan68's Avatar
 
Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 10 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Is this a late-build 2004 model year truck by any chance?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Ford Diesel/Senior/Master Tech who placed 2nd overall in Ontario on the Fix-It-Right-First-Visit score for 2010

....who works at a dealership that now employs SOME half decent looking female employees since they overhauled most of the administrative staff

....but STILL loves hot women with big boobies

....and STILL hates working on E-Series with 6.0L
m-chan68 is offline  
post #3 of 5 Old 06-10-2011, 01:34 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The year of the truck is 12/03
pimpingtp98 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-10-2011, 08:41 PM
Powerstroke Techie

 
m-chan68's Avatar
 
Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 10 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by pimpingtp98 View Post
when you first start it when it is cold it runs great. Drive about 3miles and i lose power.....i have all the low end power but no top end....when you go it starts bogging down at 2200 and wont go over 2500 when you got it to the floor....if you hold it to the floor it will blow a little bit of a white/blue smoke. the codes i found in it are as follows.....P0403,P0404,P0405,P0488,P0670,P0683,P1 102,P2262. So i cleared them and did a KOER test and got only these 3 codes. P0670,P1102,P1408. i need help i need to get this thing running i cant run my business without this truck......ANY ANSWERS
The codes highlighted in bold red are the most likely cause of the symptoms you describe. If I were to take an educated guess, I would say your EGR throttle plate is closing randomly (or is stuck closed), causing an air intake restriction and starving the engine for air. Your easiest first step would be to remove the actual throttle plate itself to see if it improves.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Ford Diesel/Senior/Master Tech who placed 2nd overall in Ontario on the Fix-It-Right-First-Visit score for 2010

....who works at a dealership that now employs SOME half decent looking female employees since they overhauled most of the administrative staff

....but STILL loves hot women with big boobies

....and STILL hates working on E-Series with 6.0L
m-chan68 is offline  
post #5 of 5 Old 07-03-2011, 04:11 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
excellent guess man. that is what it was i removed the throttle plate and it runs great....Thanks for the help
pimpingtp98 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome