P0275 new injectors,ficm,wiring harness - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-18-2019, 11:43 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
P0275 new injectors,ficm,wiring harness

I hate to start a new thread as the p0275 topic is everwhere but I cant find a good answer. I have an 05' with 138k miles. I replaced the ficm with the 58v from sinister diesel. I have a new injector wiring harness. And I replaced all 8 injectors with Warren Deisel's remams with the upgraded spool valves. The new injectos have less than 300 miles on them and the truck was running better than ever. But yesterday I got the p0275 code with a rough idle. If I shut it off and restart it it idles right and the code goes away until I give it throttle. Once i get the RPMs up it runs fine however I get the motor vibration around 1200 RPMs telling me the injector is missing. I find it very unlikely that the injector is bad. Isvit possible the injector is sticking because it hasnt been broken in yet? Any help would be greatly appreciated as im towing 14k+ in two weeks and have very limited time to fix this.
05_6.0_powerstroke1 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-18-2019, 06:25 PM
Compression Ignition Addict
 
Join Date: Apr 2012
Posts: 4,423
Thanks: 75
Thanked 331 Times in 319 Posts
Mentioned: 328 Post(s)
Quoted: 686 Post(s)
Feedback Score: 0 reviews
Does it smoke when the miss occurs?

The greater danger for most of us lies not in setting our aim too high and falling short; but in setting our aim too low, and achieving our mark.
-Michelangelo
kaya is offline  
post #3 of 6 Old 08-18-2019, 11:24 PM
Compression Ignition Addict
 
repalmer's Avatar
 
Join Date: Feb 2009
Posts: 1,475
Thanks: 0
Thanked 96 Times in 96 Posts
Mentioned: 17 Post(s)
Quoted: 563 Post(s)
Feedback Score: 0 reviews
New doesn't always equal good. Could've had some crap from fuel get stuck in it, or...
repalmer is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 08-20-2019, 01:29 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by kaya View Post
Does it smoke when the miss occurs?

It doesnt smoke


Quote:
Originally Posted by repalmer View Post
New doesn't always equal good. Could've had some crap from fuel get stuck in it, or...

It also sits most of the time as well. I put some stanadyne additives in it and the code went away but i was also only able to drive it for about 20 minutes. I intend to drive it more this weekend hopefully it doesnt come back.
05_6.0_powerstroke1 is offline  
post #5 of 6 Old 08-20-2019, 02:00 PM
,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 28,255
Thanks: 2,173
Thanked 1,805 Times in 1,749 Posts
Mentioned: 691 Post(s)
Quoted: 3899 Post(s)
Feedback Score: 0 reviews
you don't " break in" injectors I would move it to another location if you really want to rule it out
but i am betting it is the injector if you ruled out wiring and have a new FICM

6.0 flush pdf
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZMANN is online now  
post #6 of 6 Old 09-10-2019, 06:08 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
you don't " break in" injectors I would move it to another location if you really want to rule it out
but i am betting it is the injector if you ruled out wiring and have a new FICM

Sorry I've not been back for a bit. But after driving it a couple hundred miles its running better than ever with no codes. It must have been fuel or something. My alternator connector decided to fail though so now I get to chase it ha ha ha
05_6.0_powerstroke1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome