Ford Powerstroke Diesel Forum

Ford Powerstroke Diesel Forum (https://www.powerstroke.org/forum/)
-   6.0L Problems Forum (https://www.powerstroke.org/forum/6-0l-problems-forum/)
-   -   No crank, no start. Starter is good. Com issues. SCT x4 (https://www.powerstroke.org/forum/6-0l-problems-forum/1366003-no-crank-no-start-starter-good-com-issues-sct-x4.html)

Xalky 07-12-2019 01:01 PM

No crank, no start. Starter is good. Com issues. SCT x4
 
The truck started running a little funny on monday. I was running the canned performance tune from the SCT x4. I never had a problem with that tune. I got the truck home, not running horribly, check engine light never came on. Somewhere between trying to revert back to the stock tune, i got a com error on the sct x4. The errors on the sct were 21301, and also 110D8. I looked those up, and I've been trying to contact SCT to get this straightened out. Apparently The stock tune got lost , or something, according to those error codes. I've been trying to contact SCT for 2 days now and apparently the tech must be on vacation or something because I've yet to reach a tech. I keep getting a message to please call back later. Total BS!

The starter is good, I jumped it to the yellow wire on the passenger side fender...it turns over.

So in the mean time I tried to pull codes off the truck and I did get some.
B1201 Body,is a fuel sender error. The fuel guage had been acting up for about a week. No biggie.
B1352.Body. is a Ignition key in circuit failure...interesting. But it seems to be ok unless something got screwed up when i shut it off for the last time.
B2900 Body. Sets when there is a VIN mismatch between the module with the B2900 and the Powertrain Control Module (PCM). Either the PCM or the body module stored VIN may be incorrect. Read more: https://www.autocodes.com/b2900_ford.html

U0101, TCM com loss...ok now we're getting somewhere, maybe.
U1900 CAN com loss. has to do with guage cluster coms and ABS?, 4wd? I think.
u2023 fault received from external node. This seems to refer to a com loss between the ECU and some other control unit. Might be the TCM or one of the other controllers.

Thats all I got.I checked for loose plugs and chafed wiring, so far no joy.
I checked the starter relay and fuses, and Ignition relay and fuses. But I need to investigate those a little further, I ran out of time.

I got off early today to try and contact SCT during normal business hours, did I mention that they never ever answer the effing phone.

The truck ran and started, though not the greaest until I tried to load the stock tune back on it. Then Maybe the battery ran down and corrupted the download. Thats all I can think of.

I just dissconnected the batteries, to maybe hopefully reset the ECU. I'm grasping at straws here.Help!

Weird stuff.

Xalky 07-12-2019 04:40 PM

Checked all the fuses and relays. Everything is good. So now I'm leaning towards the sct x4 having screwed the ecu. Does anybody know how I can get the ecu reflashed at the dealer? Can I just take the ecu out of the truck and bring it to the dealer? I have the stock ecu and tcm strategy numbers written down.

Xalky 07-12-2019 06:01 PM

Thanks for all the help guys....NOT!

I turned the ignition key on and jumped the starter with the yellow wire. The truck started right up and ran. Now I'm getting a TBC fault code on the dash and also a Check guages fault on the dash. Truck still won't start with the key.

Johnny McG 07-13-2019 06:47 PM

Just the other day I had the 110d8 error code with my sct x4. It happened half way through downloading a custom tune. I started over and it told me something was wrong with the tune and to return the tuck from stock. While trying to reset back to stop the tuner failed again at 20%. I started to research the 110d8 error and found out that this can happen when your batteries aren't charged completely. You can hook up the tuner and check your battery level. Anything under 12 and your tuner will have issues. I put the ol trusty battery charger on and charged my batteries back up and for some reason it took 2 tries but on the second try my stock file took and then I was able to load my custom tune after. Some people said their stock tune had gotten corrupted somehow and had sct make them another to fix it but I got lucky. I hope this helps.

Sent from my SM-N960U using Tapatalk

Xalky 07-13-2019 08:47 PM

That's good info, thanks. The truck will start if I jump the starter wire, as noted above. The low battery thing is what probably happened but now I'm kinda stuck with a corrupted stock file,I believe. I read of this problem happening with a bad sct obd2 cable. I've tried to load the stock file on several times and I'll get the error at different points along the down load process, which leads me to believe my cable might be bad. So, I went ahead and ordered one. I feel like getting any kind of tech support from sct might never happen, but I'm gonna keep trying.

Johnny McG 07-15-2019 11:56 PM

Was your battery voltage good. I also read that our trucks are real sensitive when it comes to voltage and your truck can possibly run funny with low voltage as well. I know im just repeating what I said already but it would be nice if it's that simple.

Sent from my SM-N960U using Tapatalk

Xalky 07-17-2019 02:16 PM

Quote:

Originally Posted by Johnny McG (Post 16306713)
Was your battery voltage good. I also read that our trucks are real sensitive when it comes to voltage and your truck can possibly run funny with low voltage as well. I know im just repeating what I said already but it would be nice if it's that simple.

Sent from my SM-N960U using Tapatalk

Well here's what I believe happened. I went to change the tune in the truck. I decided to update the tuner prior to updating returning the truck to the stock tune. Novice mistake. During the update the truck battery went low. Then I tried to return the truck to stock. A series of screw ups and here I am with a corrupted ECU. I didn't know at the time that I could update the tuner through my computer. Make a long story short, I believe the ECU is corrupted on the truck.

If I could just load a stock profile on the ECU, I'm 99% sure this thing would fire right up. I'm not even getting Injector clicks. I checked the voltage on the ficm via the top cover. I'm getting 48.6 volts there so I don't think the Ficm is the problem.

I bought a new cable for the SCT x4 thinking that my cable was bad but I'm getting the same com error. The ECU needs to be reprogrammed. I'm not sure if I can do that with the tuner or if I have to go to the dealer. I'm trying to get ahold of SCT to see if they can load a stock tune onto my tuner. But they never answer the phone. I need to try calling them in the AM, but it's difficult because taking time off from work is very costly and the few times I tried to contact them in the afternoons, they never answered the phone. 3 days in a row.It's very frustrating. If I knew they'd answer the phone in the AM I'd take the time off to do it.

Xalky 07-17-2019 02:49 PM

Does anybody know if i can just take the PCM out of the truck and bring it to the ford dealer to have them Reprogram it? If so how much would it cost?

Johnny McG 07-18-2019 12:30 AM

I've heard you can lose the stock file if you update the x4 before returning to stock. There are companies that can fix it. I think if you can actually get ahold of sct they can sort you out for free. The companies that flash your ecu will require you to send it in to them for im guessing 100-200. You should see if any diesel shops around you can help. There's a shop by me that will flash your ecu for a fee.

Sent from my SM-N960U using Tapatalk

Xalky 07-19-2019 11:46 AM

It turns out just as I suspected all along. The SCT tuner corrupted the PCM while trying to load a tune with a week battery. I finally got ahold of tech support at SCT quite by mistake....lol. I accidentally pushed the button for tech support for vendors instead of the button for end users and PRESTO, I got put into the que and within a minute I was talking to a live person.

I'm not telling anyone to to lie but, it seems that end users are low priority at SCT. The guy at the end of the line was extremely sympathetic and helped me out even though I was not a vendor. I won't mention his name here so as not to get anyone in trouble.

Moral of the story: Don't ever call SCT tech support as an end user, but if you happen to accidentally push the button for vendors tech support, you might accidentally get to talk to a live person instead of being hung up on. Shhh.:wink:


All times are GMT -8. The time now is 01:49 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vB.Sponsors
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome