HELP ! TBC fault - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-22-2019, 09:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok so I had to apply the brakes hard getting off the freeway today and swerved around car that was parked on off ramp. I Didn’t hit anything that’s the good part but when I got to the stop light I got a warning TBC fault hmmm so I drove home shut the truck off and then turned it back on the the TBC fault was gone so scanned the codes and got U1900 and B2900 truck drives fine no ABS or engine light on I cleared the code drive 2-4 miles and nothing came back. Could this just been a fluke or could be bigger problem I just bought the truck a month ago only has 105000 on it 4x4.

Last edited by FIFTY4LIFE; 04-22-2019 at 09:56 PM.
FIFTY4LIFE is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-23-2019, 06:13 AM
Serving Our Country!
 
ChrisSki's Avatar
 
Join Date: Oct 2014
Location: Phoenix, AZ
Posts: 3,083
Thanks: 115
Thanked 266 Times in 265 Posts
Mentioned: 54 Post(s)
Quoted: 504 Post(s)
Feedback Score: 0 reviews
Are the plugs nice and snug and how does the wiring look?

I can't speak to the fault you had, but in my case I had a strap by the plug in the bed of the truck that would cause the trailer to become unplugged. With the TBC I have, I saw a no trailer sign light up, and I knew something was wrong, stopped plugged it back in, redid the strap, and it worked. Also, with the way the plug was put in the bed of the truck, the guys who installed it, spliced into the existing 5 pin and bundled the wires up and zip tied them. I would have done that a little better.

2005 F250, 189,000 Miles
Bullet Proof HD Oil Cooler w/ Cold Weather Kit, Bullet Proof EGR, Bulletproof Water Pump, 7.3 Fan Clutch
Airlift 5k Airbags and Wireless Air
Edge CTS w/ EGT probe and Fuel Pressure Sensor.
15 MPG slick; 10 MPG towing 11k fifth wheel
Ravelco

6.0 Flush Procedure:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Good 6.0 Reading:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ChrisSki is offline  
post #3 of 3 Old 04-23-2019, 06:20 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I checked everything it looked good. I just unplugged the connector and plugged it back in. I just drove it to work and no lights and no code right now it’s abiut 20 miles to my house, so I hope it was just a fluke truck runs fine right now and the TBC on the dash has not come back and the TB switch seems to work. I hope it does not come back. I am the 4th owner they used to tow with it they had a fifthwheel on it before but they took really good care of the truck.
FIFTY4LIFE is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Random cylinder contribution balance fault Tjn1994 6.0 Motor problems 17 07-17-2018 12:28 PM
TBC and ABS fault Pmtthws 6.0L Problems Forum 1 04-20-2018 08:30 PM
Power in cab (no key), every error light on dash, and TBC fault TriggerT 6.0L Problems Forum 0 08-27-2017 12:21 PM
Turning on all the headlights? GracieAllen General 6.7 Discussion (2011-2016) 5 08-13-2016 04:41 AM
Trouble with PSD dtc # 1316 bubba 1541 99-03 7.3L Powerstroke Problems 23 09-09-2009 06:23 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome