First Weak Crank No Start, Now No Crank - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-04-2016, 04:23 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
First Weak Crank No Start, Now No Crank

Hey guys,

I have my uncle's 2005 F250 6.0L PSD. About a week ago I got back from vacation and it had some trouble starting, the crank got pretty weak after 2-3 revs but then it would start up. Then a couple days later I got it started but it stalled out before I got out of the driveway. I don't know much about modern Fords, but I voltage tested the FICM and it came up lame when I tried to start it. With the key in the ON position, voltage was good (48V) but when a buddy tried to start the vehicle, the voltage started dropping. When I did this, however, the batteries were not fully charged, they read about 11.8V. I have since fully charged the batteries, but the vehicle still won't crank. Batteries do not drop below 10V when trying to start, so I think they are good. What I believe is the starter solenoid (mounted on the inner passenger side fender) clicks a lot just when the key is in the ON position, but I'm not sure that it's abnormal behavior, since I am not really familiar with this vehicle.

Since the FICM tested bad I have a mind to think it's the problem, but if the FICM is bad would that cause it not to crank? 127k miles. Thanks for any input.

Will
wgebb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-04-2016, 04:34 PM
Compression Ignition Addict
 
7.3lf550's Avatar
 
Join Date: Jul 2015
Posts: 475
Thanks: 5
Thanked 48 Times in 48 Posts
Mentioned: 4 Post(s)
Quoted: 62 Post(s)
Feedback Score: 0 reviews
A bad FICM wont affect cranking what so ever. And low battery voltage could be affecting FICM voltage. Could be weak batteries, wear solenoid, or weak starter. Have to fix the crank problem before you tackle the FICM IMO.
7.3lf550 is offline  
post #3 of 3 Old 10-04-2016, 06:12 PM
Serving Our Country!
 
cthurston09's Avatar
 
Join Date: Jun 2014
Posts: 1,464
Thanks: 1
Thanked 134 Times in 134 Posts
Mentioned: 29 Post(s)
Quoted: 368 Post(s)
Feedback Score: 1 reviews
Remove the belt and try to crank. Also unplug the fan clutch and try to crank.
cthurston09 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome