Issue with Turn Signal, overhead console, and heated seats - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-10-2018, 09:37 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Issue with Turn Signal, overhead console, and heated seats

On occasion, especially if the truck has been sitting long enough, the turn signal will not operate. Once the truck gets going after several minutes they will work again without issue.

However, I know its not the turn signal relay (I changed it just in case). When the turn signal doesn't work, the heated seats and overhead console also are not working. Sounds like this circuit shares a common ground. Any thoughts or ideas on sorting this out?
bigsnyder is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome