Need help! Dead pedal, no power til at operating temp - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-05-2018, 08:18 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Need help! Dead pedal, no power til at operating temp

2004 Ex 6.0 (build date of 02/2003) with 290k, monitor engine parameters with a scangauge ii.

Threw a P2285 and running rough, I changed the ICP sensor and no change. Towed to Dealership where they updated FICM, TCM & PCM. Dealer claimed “FICM passed test by small margin” & “possible FICM issue”. Found #1 & #6 injectors has no power.

Replaced all 8 injectors.

KOEO FMP is 48, FVP is 12, FLP is 12.

Master ASE friend suggested stuck turbo vane or VGT stuck. Tried a new VGT, no change. Did the VGT relearn, still no change.

Still has a dead pedal, chugs until 150° then idle smooths out. It takes until its at 165+ before it will even move in gear. It stumbles and has bad hesitation, but once it gets over 1k, it clears up and has minimal lag from a stop for maybe 10 min. Good throttle response after & has no issue getting up to 24psi.

KOEO ICV is .65v and ICP shows 447. I believe spec is .2 and 0 - would that indicate another faulty ICP/wiring issue?
Schaf5_04_6OH is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-05-2018, 09:49 AM
Premium Member

 
djmaguire's Avatar
 
Join Date: Oct 2014
Location: NWI
Posts: 5,995
Thanks: 170
Thanked 1,016 Times in 913 Posts
Mentioned: 241 Post(s)
Quoted: 1552 Post(s)
Garage
Feedback Score: 2 reviews
I vote harness issue. Because of your code and ICP/ICPv observation, I'd be looking at the ICP wiring internal to the harness.

You can read more about temperature-dependent wiring shorts here:

https://www.powerstroke.org/forum/6-...s-chafing.html

...with a small addendum here:

https://www.powerstroke.org/forum/ge...iscellany.html

2004 F550 CC Lariat
BPD oil cooler relocation and upgraded EGR cooler (spooled), BPD oil bypass filtration, aFe Magnum Force CAI, Mishi radiator, 7.3L fan clutch, EC1 ELC, XDP coolant bypass filtration, '08 trans pan/filter, PTP direct clutch solenoid, blue spring, 6.4 starter, MBRP y-pipe, BD boots/clamps, '05 intake elbow, ccv reroute, Torque Pro + OBDLink™ LX, Autometer EGT
djmaguire is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome