Radio install... No power - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 3Likes
  • 1 Post By voodooridr
  • 1 Post By jman37
  • 1 Post By JustinOOO9
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-19-2019, 06:46 AM Thread Starter
Powerstroke.org Fanatic
 
F(Frankenstein)-250's Avatar
 
Join Date: Aug 2018
Posts: 94
Thanks: 0
Thanked 5 Times in 7 Posts
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Feedback Score: 0 reviews
Radio install... No power

Installed new radio (long story short) had to take it out - but when I went to put it back in there was no power to the radio, so, I checked the radio fuse on the junction box and its good. The fuse on the radio is good. I bench test the radio and it's good. Triple check my wiring and it's good (ground is good). I find that Im not getting any power from the red power wire... Any ideas?
F(Frankenstein)-250 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-19-2019, 07:26 AM
Compression Ignition Addict
 
voodooridr's Avatar
 
Join Date: May 2017
Location: Monterey Bay area
Posts: 2,386
Thanks: 11
Thanked 333 Times in 311 Posts
Mentioned: 85 Post(s)
Quoted: 1055 Post(s)
Feedback Score: 1 reviews
Do your instrument cluster lights work?
Do you have illuminated visor mirrors? Do they work?
Check fuse #10 , I popped #10 installing the LED underhood light and it showed the same symptoms

Sent from my SM-G960U using Tapatalk
ZMANN likes this.

2004 F250 CCSB 4X4
4" Skyjacker lift
3:73 gears
35x12.5x18 Nitto Ridge Grapplers on Method MR309 wheels
KDD heads, ARP studs, BD exhaust manifolds, DieselSite up pipes, Mishimoto degas bottle
PHP Insight PRO
PHP Atlas 40 FICM tune
voodooridr is offline  
post #3 of 8 Old 08-19-2019, 10:41 AM Thread Starter
Powerstroke.org Fanatic
 
F(Frankenstein)-250's Avatar
 
Join Date: Aug 2018
Posts: 94
Thanks: 0
Thanked 5 Times in 7 Posts
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Feedback Score: 0 reviews
Yes cluster works fine and I don't have those type of visors. I will check the #10 fuse when I'm off work. Thanks
F(Frankenstein)-250 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 08-19-2019, 11:04 AM
Compression Ignition Addict
 
jman37's Avatar
 
Join Date: Aug 2013
Location: MA
Posts: 1,536
Thanks: 20
Thanked 87 Times in 87 Posts
Mentioned: 16 Post(s)
Quoted: 385 Post(s)
Garage
Feedback Score: 1 reviews
Here's an idea, put the stock radio back in to see if it still works...
White_Buffalo7.3 likes this.

'11 F-250 RCLB FX4 6.7 - Deleted, SCT GTX - Tyrant tuned, Duratrac's on Moto Metal 962's - Sold
'17 Grand Cherokee SRT - Stock
'97 SVT Cobra - Few things
'88 Mustang LX - Built 306ci, built AOD, 4.10's - Sold
'06 F-350 ECSB Lariat FX4 6.0 - Studded, deleted etc..-Sold
'07 F-250 XLT ECSB 4x4 6.0 - Studded, deleted etc..-Totaled
jman37 is offline  
post #5 of 8 Old 08-19-2019, 01:53 PM Thread Starter
Powerstroke.org Fanatic
 
F(Frankenstein)-250's Avatar
 
Join Date: Aug 2018
Posts: 94
Thanks: 0
Thanked 5 Times in 7 Posts
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by jman37 View Post
Here's an idea, put the stock radio back in to see if it still works...
That's a really good idea, however, I bought the truck a few years ago with an aftermarket radio... Then that was stolen... Hence, the new radio install.
F(Frankenstein)-250 is offline  
post #6 of 8 Old 08-19-2019, 01:57 PM Thread Starter
Powerstroke.org Fanatic
 
F(Frankenstein)-250's Avatar
 
Join Date: Aug 2018
Posts: 94
Thanks: 0
Thanked 5 Times in 7 Posts
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Feedback Score: 0 reviews
I do have the new radio installed and it is working but I had to wire it to a constant (orange parking light wire) but the problem is that when I shut the truck off and the radio off the clock light stays on and one.. Im afraid it will drain my battery, two, the clock is bright enough for someone to notice the stereo and steal it.
F(Frankenstein)-250 is offline  
post #7 of 8 Old 08-19-2019, 02:04 PM
Serving Our Country!

 
JustinOOO9's Avatar
 
Join Date: Nov 2012
Posts: 7,941
Thanks: 375
Thanked 695 Times in 644 Posts
Mentioned: 49 Post(s)
Quoted: 1670 Post(s)
Garage
Feedback Score: 3 reviews
Maybe a few wires were tugged on when the old radio was stolen so the wire connectors deeper in the dash are hanging on by a thread. Dig deeper in the wires (truck side) and see if a wire is barley connected et
White_Buffalo7.3 likes this.

-99 F250, 4X4, 6.0 trans cooler, 08 mirrors, 05 grill, AIS Intake, lvl kit, JW Vbody, cncfab hpop lines, WW2.

04 Excursion Modified, 04 F350 Modified, 06 F350 Modified

Interested in learning something new?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Its like me getting five 5 gallon bucks and throwing regular, mid, premium, #2 diesel and offroad diesel and then shooting a roman candle at each one to show which ones burns better."
JustinOOO9 is offline  
post #8 of 8 Old 08-19-2019, 04:45 PM Thread Starter
Powerstroke.org Fanatic
 
F(Frankenstein)-250's Avatar
 
Join Date: Aug 2018
Posts: 94
Thanks: 0
Thanked 5 Times in 7 Posts
Mentioned: 2 Post(s)
Quoted: 11 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by JustinOOO9 View Post
Maybe a few wires were tugged on when the old radio was stolen so the wire connectors deeper in the dash are hanging on by a thread. Dig deeper in the wires (truck side) and see if a wire is barley connected et
I'll check the wires again, the thing is... The new radio was already installed and working fine... I had to take it out to connect to rear camera, and after I reinstalled it the issue started.
F(Frankenstein)-250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome