07 f250 6.0 power stroke trans high vacuum noise losing power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-21-2019, 08:19 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 1 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
07 f250 6.0 power stroke trans high vacuum noise losing power

My truck when its cold runs fine after around 10-20 miles and the truck heats up a little I have a high vacuum noise and my transmission seems like it loses power and it goes in and out any suggestions. I already did a fluid change and changed filters Thanks
Jl0520 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
11-16 FORD F250 TOW MIRRORS POWER HEATED POWER FOLD POWER TELESCOPE CHROME CAPS 1AAuto.com 1A Auto Parts 0 01-25-2017 10:56 AM
2010 XLT F250 Power Stroke Caught Fire anndeezzz General 6.4L Discussion 26 11-30-2016 04:52 PM
Power Stroke Clutch noise Joepel43 General Diesel Discussion 1 06-15-2006 06:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome