Reoccurring injector code - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-04-2019, 04:37 PM Thread Starter
Member
 
Join Date: Aug 2018
Posts: 73
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
Reoccurring injector code

I own an 03 f250 6.0l with 213k miles. I had a new bulletproof egr cooler and oil cooler, and injectors 1,5,8 installed shortly after I bought it at 208k miles. I didnt have the money at the time to stud it and wish I would have. I later ended up doing the remaining injectors after I had a # 4 fail. I had a p0263 code that kept coming back and the diesel shop replaced it 2 more times to try and fix it since nothing showed up in tests. I found a similar event on another members post where he mentioned the oil rail check valve. I ordered 2 new ones and replaced both sides. The p0263 hasnt returned but now it seems the issue I'm having is a reoccurring p0278 code. The strange part is, like the p0263 I was getting, it only happens when my truck is idling at a light and the ect gets to 154-158*. Its pretty precise. I only notice a slight change in idle smoothness and pull the codes with the edge cts2. I've been to my normal diesel shop that's done all the work, to Ford dealer, and made several calls to other shops. Nobody else seems to have come across this. All new injectors, new ficm, new wire harnesses(injector and engine), s&b intake, running Rotella t6 and use cetane additive with every fill up. I've ruled out tune, as it does it in stock mode. Now I'm unplugging Edge monitor all together. I dont know where else to go with this.
Tathag is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-04-2019, 05:26 PM
Compression Ignition Addict
 
7.3lf550's Avatar
 
Join Date: Jul 2015
Posts: 521
Thanks: 5
Thanked 49 Times in 49 Posts
Mentioned: 4 Post(s)
Quoted: 72 Post(s)
Feedback Score: 0 reviews
That would be cylinder 1 and 6 i believe. Both of which have nothing in common other than the FICM connector. cylinder 1/4/6/7 are all on plug A. i would start there. Unless the shop has moved injectors around at somepoint.

Verify that the FICM plugs are in all of the way and free of water.

Verify that the wires are not chaffed where they make the 90 degree bend right near the FICM.

Change the FICM with a know working one. Could be a logic board problem in the FICM.
7.3lf550 is offline  
post #3 of 5 Old 09-04-2019, 05:46 PM Thread Starter
Member
 
Join Date: Aug 2018
Posts: 73
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by 7.3lf550 View Post
That would be cylinder 1 and 6 i believe. Both of which have nothing in common other than the FICM connector. cylinder 1/4/6/7 are all on plug A. i would start there. Unless the shop has moved injectors around at somepoint.

Verify that the FICM plugs are in all of the way and free of water.


Verify that the wires are not chaffed where they make the 90 degree bend right near the FICM.

Change the FICM with a know working one. Could be a logic board problem in the FICM.
That's where I began when I had it originally on the #1 injector. Found a cooked section of harness right in front of the turbo and thought maybe that was the problem so I replaced all the harnesses with new OEM's just to rule all of that out. Still occurred. Then I replaced I ficm with a new Ford ficm from dealer. I keep leaning towards maybe am interface with the edge monitor. Any thread I've found with anyone slightly similar, all had the edge tuner/monitor in common. My diesel mechanic told me early on that the edge tuners didn't work well with the 6.0s and I should switch to the SCT. I'm starting to think he was right.
Tathag is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 09-04-2019, 05:52 PM
Compression Ignition Addict
 
7.3lf550's Avatar
 
Join Date: Jul 2015
Posts: 521
Thanks: 5
Thanked 49 Times in 49 Posts
Mentioned: 4 Post(s)
Quoted: 72 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Tathag View Post
That's where I began when I had it originally on the #1 injector. Found a cooked section of harness right in front of the turbo and thought maybe that was the problem so I replaced all the harnesses with new OEM's just to rule all of that out. Still occurred. Then I replaced I ficm with a new Ford ficm from dealer. I keep leaning towards maybe am interface with the edge monitor. Any thread I've found with anyone slightly similar, all had the edge tuner/monitor in common. My diesel mechanic told me early on that the edge tuners didn't work well with the 6.0s and I should switch to the SCT. I'm starting to think he was right.
I have never ran edge, only SCT so i am not sure on that. But as you said, the best way to solve that issue is to remove the edge and see what happens.

THe worst case could be that you have injectors failing already. Where did you buy them from?
7.3lf550 is offline  
post #5 of 5 Old 09-04-2019, 06:15 PM Thread Starter
Member
 
Join Date: Aug 2018
Posts: 73
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by 7.3lf550 View Post
Quote:
Originally Posted by Tathag View Post
That's where I began when I had it originally on the #1 injector. Found a cooked section of harness right in front of the turbo and thought maybe that was the problem so I replaced all the harnesses with new OEM's just to rule all of that out. Still occurred. Then I replaced I ficm with a new Ford ficm from dealer. I keep leaning towards maybe am interface with the edge monitor. Any thread I've found with anyone slightly similar, all had the edge tuner/monitor in common. My diesel mechanic told me early on that the edge tuners didn't work well with the 6.0s and I should switch to the SCT. I'm starting to think he was right.
I have never ran edge, only SCT so i am not sure on that. But as you said, the best way to solve that issue is to remove the edge and see what happens.

THe worst case could be that you have injectors failing already. Where did you buy them from?

They are Ford OEM injectors. The diesel shop I go to only uses Ford outside of bulletproof egr coolers and the proven parts. The other threads I found that are similar never post closure so I'm stuck other then this.
Tathag is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome