Trailer brake controller - Ford Powerstroke Diesel Forum
Wheels, Tires, and Brakes Here's where you can post all your topics and questions about wheels, tires and brakes.
Sponsored by Discount Tire

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-17-2012, 03:46 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trailer brake controller

I have a 2009 f250 diesel with onboard TBC. When towing my 5th wheel i get no trailer braking when the brake pedal is applied. When I use the manual slide the trailer brakes work fine and I get a gain display in the control panel display. I get no indicator when using the brake pedal. I checked all fuses and all are good both under the hood and in the kick panel. The trailer is new 2013 and the truck has 16000 miles. All connectors at the trailer plug appears new and without any issues. I am baffled yet when searching the net see others with the same problem and other than a fuse or bad connector no real answers. Help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-08-2012, 06:03 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I see I have a lotta looks but no replies. Well for those interested in the trailer brakes not working, I took the truck to the dealer who has a diesel shop. The problem baffled them for a week. Finally they ordered the brake pressure transducer, new rear wire harness and a switch that goes to the cruise control. Basically most everything except the controller. A great shotgun approach on their dime. When I got it back it actually worked. Now I have brakes with the brake pedal and it displays on the dash.

The moral of the story, since i researched many sites on Google and never could find a fix. BTW the pressure switch was put in first and it still didnt work so the other parts were installed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors