97 F350 ABS light and Brake warning light - Ford Powerstroke Diesel Forum
Wheels, Tires, and Brakes Here's where you can post all your topics and questions about wheels, tires and brakes.
Sponsored by Discount Tire

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-23-2012, 05:36 AM
Member
 

Join Date: Nov 2011
Location: NW Iowa
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 F350 ABS light and Brake warning light

97 CCLB, I haven't done any brake work on it, only thing I've done is top off the brake fluid to see if that would shut off the brake warning light. That light turned on and off periodically as I was driving, sometimes it would just flicker like it was trying to shut off. Most recently, I ended up having to drive through a pasture area that was quite muddy. Needless to say I had to try the 4X4 to get around. As I was leaving the ABS light came on and hasn't shut off since. Is there mud somewhere that could be causing this and what causes the brake warning light to come on like that? All the help is appreciated.
Andy
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-30-2012, 01:52 PM
Member
 

Join Date: Nov 2011
Location: NW Iowa
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Still have lights on, ABS light turns on 2 seconds after truck is started. Any advice would help.
Reply With Quote Quick reply to this message
  #3  
Old 08-30-2012, 01:57 PM
Banned
 

Join Date: Jun 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the third brake light, bad light or your running a led light maybe? i run a led third brake light in my three osd's and all three had a abs light come on take them off and they went out? idk if it helps you any. thanks calvin
Reply With Quote Quick reply to this message
  #4  
Old 08-31-2012, 07:49 AM
Member
 

Join Date: Nov 2011
Location: NW Iowa
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Checked my taillights this morning, both work. My 3rd tail had no bulb in it so I put one in, didn't fix it. Worth a shot I guess, thanks
Reply With Quote Quick reply to this message
  #5  
Old 09-21-2012, 01:44 PM
Member
 

Join Date: Nov 2011
Location: NW Iowa
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
WAS A CRACKED BRAKE LINE GOING TO THE REAR, THE ONE BETWEEN THE FRAME AND THE FUEL TANK. ALL FIXED UP NOW
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors