Brake lights don't work but fuses not blown - Ford Powerstroke Diesel Forum
Wheels, Tires, and Brakes Here's where you can post all your topics and questions about wheels, tires and brakes.
Sponsored by Discount Tire

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-2011, 05:19 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 241
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Brake lights don't work but fuses not blown

I was wondering if someone could give any suggestions. I know electrical problems can be a real pain ... but

I have a 2002 F250 Diesel 7.3 2WD

Brake lights don't work. not sure when they stopped working but couldnt have been more than a couple months. Tried changing the Brake switch at the brake pedal but didnt correct the problem. Checked all fuses on the fuse panel and everything tests. Checked every fuse with a fuse tester.

Does anyone have a diagram that labels what fuse goes to what?????

Any suggestions would be appreciated
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-13-2011, 06:21 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 241
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Suggestions Anyone?

Can anyone offer any thoughts???

I have double checked all of the fuses again and they are good. I have done some research and on the Relay's and do not see a Relay for the Brake Lights, only see relays for Anti-Lock Brake, Trailer Tow and other things not related to brakes.

Again i have replaced the Brake light switch that connects to the brake pedal - When i press the brake pedal i do not hear or feel any clicking - if there is a relay for the Brake lights can anyone help determine which relay it is?

All other lights work - when i connect my boat trailer the lights come on like normal but the Brake lights on the trailer dont work either

Thanks in advance for any suggestions anyone might have
Reply With Quote Quick reply to this message
  #3  
Old 04-13-2011, 06:38 AM
Conservative and Proud


 

Join Date: Nov 2005
Location: Oregon
Posts: 14,472
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I've got the fuse diagram somewhere on my computer.... give me a few to find it for ya!
Reply With Quote Quick reply to this message
  #4  
Old 04-13-2011, 06:41 AM
Conservative and Proud


 

Join Date: Nov 2005
Location: Oregon
Posts: 14,472
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews







Reply With Quote Quick reply to this message
  #5  
Old 04-13-2011, 07:32 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 241
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Banshee34, thanks for the post

yeah, i did find this diagram and reviewed it but all of my fuses check out and the Relays listed in the diagram do not specify anything about Brake Lights, unless i am complete overlooking something.

Other than the Fuses, Relays and the Brake Light Switch, What else is there???

thanks again
Reply With Quote Quick reply to this message
  #6  
Old 04-13-2011, 07:54 AM
Conservative and Proud


 

Join Date: Nov 2005
Location: Oregon
Posts: 14,472
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Besides possibly a short, I don't know.... so.....

Reply With Quote Quick reply to this message
  #7  
Old 04-17-2011, 07:30 AM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Prince George, British Columbia
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had this problem on an 04 company truck. Took it to the shop and it was some sort of switch in the steering column. Cost about $200 to fix.
Reply With Quote Quick reply to this message
  #8  
Old 04-22-2011, 09:20 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
could possibly be the multi function switch in the column, take the covers off of the column and bring it up to autozone and ask if theyll let you just switch the multifunction switch out to see if thats whats wrong, its only two screws after you have the covers off. do your blinkers work?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors