injector issue - Ford Powerstroke Diesel Forum
What is This? Everything you wanted to know about the TECH Exchange

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-07-2012, 12:51 PM Thread Starter Rookie
Join Date: Nov 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
injector issue

I have searched forum and cant find information on this. I have a 2000 ford powersroke. I have hard start issues. When it does start it will lope and spew black smoke like fuel is flooding out a cylinder.Will start easier and loping and black smoke isnt as long with block heater plugged in. Recent test showed number 2 cylinder fault. I took off valve cover for driver side and observed #2 and #4 injector not deflecting any oil. My question is can the harness be the culprit or are the injectors mechanically bad? I know the oil not deflecting the injector is not working but can it be electrically through the harness or is the oil not deflecting out because it is mechanically bad?
coldbillie is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome