Hot electrical smell 2000 F-350 7.3 turbo - Ford Powerstroke Diesel Forum
What is This? Everything you wanted to know about the TECH Exchange

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-20-2012, 09:07 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2012
Location: Alaska
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hot electrical smell 2000 F-350 7.3 turbo

Hot electrical smell when I pre-heat then start my 7.3. I just changed the alternator and it runs fine but search as I might I can't find hot wires or observe smoke etc.

Has anyone else had this issue?
Jackinalaska is offline  
post #2 of 2 Old 11-01-2012, 06:40 AM
Member
 
billman's Avatar
 
Join Date: Jul 2008
Location: Central NY
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If it is inside the cab and you have an auto, the od wire rubs raw and will cause issues. if it is shorting you may get a smell. this is an easy fix with electrical tape and will happen eventually so fix it now.

2002 Exscursion 7.3, PHP Gryphon, DFA V3, V& Modded B codes, 6.0 Tranny cooler, 285/75/16 Nitto Duragrapplers, Pulling a 26' TT. 180k/mi and counting.
billman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome