Trailer brake issues - Ford Powerstroke Diesel Forum
What a Powerstroke is for, Towing and Hauling FAQs, How To's, What do you pull, 5ers

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-23-2013, 04:11 PM Thread Starter Rookie
Join Date: Sep 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trailer brake issues

Good day gents. Been snooping around this site for a bit now. Pleased to say I just bought my 5th new F-350 diesel Lariat since 2001 (2013). So far truck has been a pleasure to drive.

I hauled my trailer for work year around. One thing that has me a little confused to this point is. When I plugged my trailer into my truck for the first haul. I checked lights, hazards, ect. I drove out of my yard & drove about 25 km before I had to use the brakes. Once I applied the brake pedal, I had no braking action at the trailer. Reached over & applied the factory hand break bingo, I had brakes. Pulled the trailer 600 km & tested it several times with the same results.

I had to change some spring shackles on the trailer once I got to my destination. Jacked the trailer up so the tires were off the ground. With my trailer plugged into my truck, I had a couple guys spin the trailer tires by hand. Once again when pressure the brake pedal they would not stop. Tried again with the factory hand brake & sure enough the brakes would engage.

I'm sure I'm missing something but a little stumped.

Conducted these tests with brake settings at different power levels.
Same old trailer.Installed a new plug in end on the trailer. Done it a few times so not to worried about any issues with it.

Any input would be grateful
Strokered is offline  
Sponsored Links
post #2 of 2 Old 09-23-2013, 04:47 PM
Compression Ignition Addict
Rexter's Avatar
Join Date: Jul 2012
Location: College Station
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
what was the gain setting on the controller?
did you set the brake gain before driving?
if not, set it first. start at 0, truck in gear. adjust gain up til controller will hold the truck still.
if still no trailer brakes, sounds like an electrical problem.
Rexter is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome