Tranny is TOASTED HELP - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-16-2008, 05:42 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Mar 2008
Location: Sonora
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Tranny is TOASTED HELP

Ok guys I was driving the other day and when i came to a stop my truck was serging like the brakes werent holding but I knew it was transmission..so I turned my OD on and it quit...then I turned my OD back off and started driving and my RPM was going up but my speed wasnt..so finally I pulled over and now if I put it in Drive 2nd or 1st it wont move..but reverse is fine? I got quoted 2300$ and change for one from ford but 3800$ for a heavy duty one. Can I buy a heavy duty rebuild kit somewhere and stay in the 1000-2000$ max range?? I was told also it could just be a bad torq converter? any ideas???
DougDavenport is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-16-2008, 05:49 PM
Stupidity pisses me off

 
sevenmalards's Avatar
 
Join Date: Dec 2006
Location: West Sacramento
Posts: 3,830
Thanks: 10
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by DougDavenport View Post
Ok guys I was driving the other day and when i came to a stop my truck was serging like the brakes werent holding but I knew it was transmission..so I turned my OD on and it quit...then I turned my OD back off and started driving and my RPM was going up but my speed wasnt..so finally I pulled over and now if I put it in Drive 2nd or 1st it wont move..but reverse is fine? I got quoted 2300$ and change for one from ford but 3800$ for a heavy duty one. Can I buy a heavy duty rebuild kit somewhere and stay in the 1000-2000$ max range?? I was told also it could just be a bad torq converter? any ideas???
Are you running a programmer?

2006 F350 CREW CAB LONG BED KING RANCH

99.5 F350 Super Cab Long Bed, Dually.
SOLD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.







Quote:
Originally Posted by SMKSTAX View Post

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
You are not right man, but i still think your funny as hell!
sevenmalards is offline  
post #3 of 4 Old 05-16-2008, 08:14 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Mar 2008
Location: Sonora
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes I have a chip its an oldschool superchip that is 45 HP i think nothing crazy.
DougDavenport is offline  
post #4 of 4 Old 07-13-2008, 02:10 PM
Powerstroke.org Rookie
 
nighthawk46563's Avatar
 
Join Date: May 2007
Location: Northwest Indiana
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like your support bearing is out. Mine has gone out twice and the shop that fixed it wont warranty it $2500 in the toilet. Take the trans pan off the truck and see if you have little strands of metal on the magnet. If you do its probably the support bearing.
nighthawk46563 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome