2005 F-250 Tranny Problem after new FICM??? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-26-2012, 05:22 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2005 F-250 Tranny Problem after new FICM???

Don't know what to do here. I had my FICM replaced a few weeks ago, and just recently downloaded and installed a new update for my Diablo Predator. Installed the "performance tune" about a week ago, and all has been going well.....power improvement, great shifting, and the fuel mileage is better.

Something really odd happened today. I was driving casually at about 60 mph, went to accelerate, and my RPM's shot way up then the transmission shifted VERY hard, and then the speed started to decrease, while RPM's were still up....This happened off and on for about 20 miles until I got home (the tranny shifted so hard at times, I thought it was going to blow). I restored to original back up on my Predator, and went for a drive. No problems.

Tuner problem?
Trans gone?
Sensors?

Thoughts?

Thanks!

Eric D
2005 F-250 4x4
158,200 Miles
Dawgman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome