Slave cylinder fail! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-2011, 09:20 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Burlington, NC
Posts: 999
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
Slave cylinder fail!

So I was on my way to work today, then with about a mile to go, as I shift into 3rd my clutch pedal drops to the floor! After a quick bit of panicing, I end up floating the gears the rest of the way into work. After a few minutes of diagnosing, I found the line loose at the back of the slave cylinder. I had replaced this entire assembly (the pre-bled kit from Ford) back in Feb. And that was after I had replaced my clutch with a new OE grade Valair clutch.

My question is; these stock hydraulic components are supposed to be able to handle aftermarket clutches, right? Did I just get a defective part? It only lasted 4 months!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-05-2011, 09:40 PM
spool up that turbo!!


 

Join Date: Oct 2010
Location: ridgefield wa
Posts: 2,008
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by nccatfan View Post
So I was on my way to work today, then with about a mile to go, as I shift into 3rd my clutch pedal drops to the floor! After a quick bit of panicing, I end up floating the gears the rest of the way into work. After a few minutes of diagnosing, I found the line loose at the back of the slave cylinder. I had replaced this entire assembly (the pre-bled kit from Ford) back in Feb. And that was after I had replaced my clutch with a new OE grade Valair clutch.

My question is; these stock hydraulic components are supposed to be able to handle aftermarket clutches, right? Did I just get a defective part? It only lasted 4 months!
The pre bled kits are hit and miss I've had the tabs of the slave cylinder actually snap and fell out of the bellhousing and have ha the line leak the local shop replaced mine for free
Reply With Quote Quick reply to this message
  #3  
Old 05-05-2011, 09:45 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Burlington, NC
Posts: 999
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
Is there an upgrade for this? If the next one fails I'd like to go to something more reliable.
Reply With Quote Quick reply to this message
  #4  
Old 05-05-2011, 10:14 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 1,076
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I just replaced master and slave cylinder on mine. I would think a stock slave would be fine. Correct me if I'm wrong someone . The pre bled kit from Ford is a rip off. I took the whole system off and put the new parts on the stock line and had it bled and back on in 30,minutes with no problems. Also the factory slave is plastic , well least on mine it was and I replaced it with a metal heavy duty slave. Maybe try that
Reply With Quote Quick reply to this message
  #5  
Old 05-05-2011, 10:18 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 1,076
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
forgot to mention also replaced master with heavy duty metal. I think I got these at advance auto
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:58 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors