Slave cylinder fail! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 05-05-2011, 10:20 PM Thread Starter
Compression Ignition Addict
 
nccatfan's Avatar
 
Join Date: Sep 2007
Location: Burlington, NC
Posts: 1,007
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
Slave cylinder fail!

So I was on my way to work today, then with about a mile to go, as I shift into 3rd my clutch pedal drops to the floor! After a quick bit of panicing, I end up floating the gears the rest of the way into work. After a few minutes of diagnosing, I found the line loose at the back of the slave cylinder. I had replaced this entire assembly (the pre-bled kit from Ford) back in Feb. And that was after I had replaced my clutch with a new OE grade Valair clutch.

My question is; these stock hydraulic components are supposed to be able to handle aftermarket clutches, right? Did I just get a defective part? It only lasted 4 months!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-'99 F250 7.3L PSD 4x4 (SCLB, 6-speed)
-'14 F150 4x4 5.0 CCSB
-'83 Ranger 4X4 5.0

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nccatfan is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-05-2011, 10:40 PM
spool up that turbo!!


 
hollister25073's Avatar
 
Join Date: Oct 2010
Location: ridgefield wa
Posts: 2,008
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by nccatfan View Post
So I was on my way to work today, then with about a mile to go, as I shift into 3rd my clutch pedal drops to the floor! After a quick bit of panicing, I end up floating the gears the rest of the way into work. After a few minutes of diagnosing, I found the line loose at the back of the slave cylinder. I had replaced this entire assembly (the pre-bled kit from Ford) back in Feb. And that was after I had replaced my clutch with a new OE grade Valair clutch.

My question is; these stock hydraulic components are supposed to be able to handle aftermarket clutches, right? Did I just get a defective part? It only lasted 4 months!
The pre bled kits are hit and miss I've had the tabs of the slave cylinder actually snap and fell out of the bellhousing and have ha the line leak the local shop replaced mine for free


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 f250 4dr LB 6spd
s&b, cfm+
4in straight pipe
DP tuner
boost pyro and engine oil temp
AIH delete, hpx, frx
05 harleys 8000k's
billet grille and painted shell
17"welds and 35-12.5's toyo mt's
cab lights
southbend con ofe waiting to go in
fresh 7.3 from reviva


SOLD
1995 f150 302 5spd 35's sad sad day


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hollister25073 is offline  
post #3 of 5 Old 05-05-2011, 10:45 PM Thread Starter
Compression Ignition Addict
 
nccatfan's Avatar
 
Join Date: Sep 2007
Location: Burlington, NC
Posts: 1,007
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
Is there an upgrade for this? If the next one fails I'd like to go to something more reliable.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-'99 F250 7.3L PSD 4x4 (SCLB, 6-speed)
-'14 F150 4x4 5.0 CCSB
-'83 Ranger 4X4 5.0

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nccatfan is offline  
post #4 of 5 Old 05-05-2011, 11:14 PM
Compression Ignition Addict
 
at0075's Avatar
 
Join Date: Feb 2011
Posts: 1,076
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I just replaced master and slave cylinder on mine. I would think a stock slave would be fine. Correct me if I'm wrong someone . The pre bled kit from Ford is a rip off. I took the whole system off and put the new parts on the stock line and had it bled and back on in 30,minutes with no problems. Also the factory slave is plastic , well least on mine it was and I replaced it with a metal heavy duty slave. Maybe try that

2004 f350 6.0, 6spd, studs, 175/stock warrens, deleted, blue spring, 6.4 banjos, strait 4 in exhaust, zoo dad mod, 35s, 3.5 in lift,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
at0075 is offline  
post #5 of 5 Old 05-05-2011, 11:18 PM
Compression Ignition Addict
 
at0075's Avatar
 
Join Date: Feb 2011
Posts: 1,076
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
forgot to mention also replaced master with heavy duty metal. I think I got these at advance auto

2004 f350 6.0, 6spd, studs, 175/stock warrens, deleted, blue spring, 6.4 banjos, strait 4 in exhaust, zoo dad mod, 35s, 3.5 in lift,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
at0075 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome