No Trans Temp, Check Gauges and Flashing Tow Haul - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2011, 09:07 AM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No Trans Temp, Check Gauges and Flashing Tow Haul

Well last night when having the water in fuel light on, I also have the Temp gauge just sudden drop from normal temperatures to below C. and the Tow Haul light started flashing and the check gauges light was on.

So after I drain out the water from my tank, start my truck backup and everything was normal, the temp gauge was working and was slowly creeping up to where it normally would be and such.

Leaving this AM for work I'm halfway to work and I see it again, gauge drops, Tow haul flashing and the check gauge light is on. Truck is running fine, shifting fine and so on.

Drive to the advanced auto parts ask them to pull codes and when we go back out, everything it back to normal, no code. So shutting it off seems to reset what ever is going on. So I buy a small OBD2 scanner and as im going back home to change vehicles, and the lights come back on so I plug in the scanner and no codes.

So after reading the forums I'm thinking its the Trans Temp Sensor? Does this sound right?

HELP! When it rains it pours!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-09-2011, 09:09 AM
Member
 

Join Date: Jan 2011
Location: surprise
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had this happen to my 04 6.0 and it was the trans temp sensor the gauge would drop and the tow haul light and check engine light would come on replaced the sensor and all good but mins stored a code
what year and what engine do you have?
Reply With Quote Quick reply to this message
  #3  
Old 03-09-2011, 09:11 AM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 5,502
Thanks: 2
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
the scanner you used more than likely wont show any codes, it probably cant read them.
Reply With Quote Quick reply to this message
  #4  
Old 03-09-2011, 09:22 AM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ktmrider686 View Post
i had this happen to my 04 6.0 and it was the trans temp sensor the gauge would drop and the tow haul light and check engine light would come on replaced the sensor and all good but mins stored a code
what year and what engine do you have?

2004 6.0L Excursion
Reply With Quote Quick reply to this message
  #5  
Old 03-09-2011, 03:59 PM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by evilnss View Post
2004 6.0L Excursion
Ended up being the sensor... well atleast so far! I will keep you posted if something changes.

Thanks for your help.
Reply With Quote Quick reply to this message
  #6  
Old 06-02-2011, 08:28 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im having the same problem right now but my od light is flashing and my speedo is going up and down when i drive down the road
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors