TANNY HELP ASAP PLEASE!!!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-09-2010, 02:18 PM
Chapter Director
 

Join Date: Feb 2010
Location: Vacaville, CA
Posts: 2,200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation TANNY HELP ASAP PLEASE!!!!!

so i just got done installing a Factorytech VB and a PI stalion TC put the proper amount of fluids in even aded an extra 40k cooler and inline filter.
i did the front pump mods required for the TC.

so i went for a test drive and 1-2 shifted perfect, 2-3 banged into gear real hard then after that i wouldnt go into 3 under acceleration, so i let off the trhottle and it would immediately shift into 3rd but back on the throttle it will go back into 2nd

what is wrong with my truck. i need it to be fixed by the end of the week. is it something that i did that screwed up my tranny or is it just toast. please help i already dumped a ton of money ionto the tranny and really dont want to have to have it rebuilt
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-09-2010, 02:19 PM
Chapter Director
 

Join Date: Feb 2010
Location: Vacaville, CA
Posts: 2,200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oh and the temps got to 190* real quick normally i barely reach 160*
Reply With Quote Quick reply to this message
  #3  
Old 06-09-2010, 03:45 PM
Chapter Director
 

Join Date: Feb 2010
Location: Vacaville, CA
Posts: 2,200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well just checked all connections everything on the outside looks good. went for a test drive again same thing i mentioned above and now no reverse until you give some trhottle then it slams into reverse.
Reply With Quote Quick reply to this message
  #4  
Old 06-09-2010, 08:22 PM
Chapter Director
 

Join Date: Feb 2010
Location: Vacaville, CA
Posts: 2,200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok got the fluid levels perfect. it shifts 1-2 fine the the TC locks up then 2-3 is real hard then 4/od is normal. sometimes the 2-3 shift is normal but then i have no reverse, after i get reverse to engage it shifts hard 2-3 and wont go into 4th. any ideas would be greatly appreciated
thanks Jordan
Reply With Quote Quick reply to this message
  #5  
Old 06-09-2010, 08:28 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Hedgesville, WV
Posts: 1,256
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It could be an issue with the valve body......
Reply With Quote Quick reply to this message
  #6  
Old 06-09-2010, 08:30 PM
Tennessee Powerstrokes

 

Join Date: Mar 2009
Location: Lebanon TN
Posts: 2,819
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Dayum Man I am sorry to hear about your issues, but if the trans all worked fine before the upgrades I would say it is something to do with that. I personally would give BTS a call and tell tham the symtoms and maybe they could help.
Reply With Quote Quick reply to this message
  #7  
Old 06-09-2010, 08:46 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Hedgesville, WV
Posts: 1,256
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Re-reading this thread makes me think it isnt locking/unlocking the tc like it should... It would explain the need for revs to get into reverse and the hard 3rd shift....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors