HELP! loud clunk now tranny wont downshift - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-08-2009, 10:59 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
HELP! loud clunk now tranny wont downshift

hey guys i was driving up a small hill tonite coming into town and i got on the gas a little and my truck made a loud clunk which sounded like it came from the tranny and then now it wont downshift and acts like its slipping when it when you get on the gas.. the truck is stock and i just got it a few days ago and it had a rebuilt tranny not too long ago.. it shifts and goes fine at low throttle but as soon as you give it more throttle the problem happens.. thanks for any help
teamgreen248 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-08-2009, 11:42 PM
Premium Member
 
GreenF350's Avatar
 
Join Date: Jan 2007
Location: Florida Panhandle
Posts: 1,710
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have you tried running it through the gears manually? I'm not REAL familiar with these transmissions, but I know most have a one way clutch or two in them that might have let loose in yours. Just an idea. Like I said, I don't know these transmissions real well.
-Aaron

2000 Ext. Cab F350 SRW, 6" Skyjacker lift on front/8" BDS Springs on rear w/NO blocks, 37x13.50 Nitto Mud Grappler's, Aftermarket Front Bumper

-Always More Stuff Coming!
GreenF350 is offline  
post #3 of 3 Old 11-10-2009, 11:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
well i feel like an idiot lol. turns out nothing at all happened to the tranny.. my interrcooler line blew off the turbo which is what made that bang.. but for some reason it sounded like it was under the truck. and since it had no boost it made no power which felt like to me the tranny was slipping.. simple fix and shes as good as new. thanks for the help
teamgreen248 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome