new here, need HELP - Ford Powerstroke Diesel Forum
Testing Forum Dont know how to post a poll, picture, Etc....Try it out here first!!

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-27-2009, 03:36 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
new here, need HELP

new to the site, as you have heard, lot's of great info. I need some more help though. 97' f350 c/c 4x4 4.11 gears auto. Real sluggish take off and loosing power going up the larger overpasses on the highway...EMPTY. Already changed ff and af 3" dp and dual 5" stacks. Injectors rebuilt in Jan and fuel pump last month. Cleaned the screen on regulator and have 55psi @ idle. oh and new ipr and cleaned ebp tube. anything else? When I say sluggish, a mini van full of kids took off from me at a stop!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-27-2009, 03:44 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,241
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bad turbo take your cold air intake off and check for shaft play on the turbo blades. do you have a boost gauge?
Reply With Quote Quick reply to this message
  #3  
Old 06-27-2009, 04:13 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no, not yet. i checked the turbo when i rebuilt the injectors and had very little play. Also very little black smoke. turbo whistles through the rpms
Reply With Quote Quick reply to this message
  #4  
Old 06-27-2009, 04:41 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,247
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
the ebp valve is probably shutting off , even if there were alot play in the turbo, if all components were in tact , it will spool, old body style were world worse for shutting the ebp valve off when it wasnt supposed to, unplug the 2 wire connector goin to the pedestal and see if it makes a difference

Last edited by SCUFFY828; 06-27-2009 at 07:05 PM.
Reply With Quote Quick reply to this message
  #5  
Old 06-27-2009, 06:13 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
will do. if nothing changes?
Reply With Quote Quick reply to this message
  #6  
Old 06-27-2009, 06:45 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Posts: 2,027
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
might be time to rebuild your turbo or get a new one
Reply With Quote Quick reply to this message
  #7  
Old 06-27-2009, 07:07 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,247
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bill315 View Post
will do. if nothing changes?
let me know , we can dig deeper , i still dont think its your turbo, so dont just buy one
Reply With Quote Quick reply to this message
  #8  
Old 06-27-2009, 07:11 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
idk if the obs diesels smoked real bad on take off or not,but mine doesn't hardly at all.will def try the plug after little bit, thanks!
Reply With Quote Quick reply to this message
  #9  
Old 06-27-2009, 07:15 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Posts: 2,027
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bill315 View Post
idk if the obs diesels smoked real bad on take off or not,but mine doesn't hardly at all.
it wont untill you start moding it
Reply With Quote Quick reply to this message
  #10  
Old 06-27-2009, 07:17 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,247
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bill315 View Post
idk if the obs diesels smoked real bad on take off or not,but mine doesn't hardly at all.will def try the plug after little bit, thanks!
smoke depends on tuning , in stock form none of them smoke that much, cant really go by that , do you have a tuner or chip
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:13 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors