Power steering pump reservoir - Ford Powerstroke Diesel Forum
Suspension & Steering Discuss OEM & aftermarket suspension, lifts, air ride suspension, shocks, steering components, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-31-2014, 01:45 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2013
Location: McGuire AFB, NJ
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Power steering pump reservoir

So I broke the plastic nipple off the bottom of the power steering pump, the pump itself is good, just the reservoir is broken, what does it take to pull the reservoir off the pump and replace it? I know it's possible since autozone sells the reservoir alone, but I cant quite figure it out.

2001 F350 XLT 7.3 Powerstroke SRW Crew Cab 4x4. "Straight Pipe" Exhaust, High Idle Mod
msimpson619 is offline  
post #2 of 3 Old 01-31-2014, 03:47 PM
Powerstroke.org Sponsor

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 9,642
Thanks: 803
Thanked 533 Times in 487 Posts
Mentioned: 200 Post(s)
Quoted: 508 Post(s)
Feedback Score: 1 reviews
They do just sell the reservoir. Iirc there's a clip then it pops straight up.

Have you ever had feelings for a nun??? "Nacho Libre"

E99CCLB 450/400s,STG1cam, KC38R, 4" exh,CNC FAB fuel&oil lines,140vIDM,BTS,S&B

97 ECLB F250 4x4 stock
96 CCLB F350 4x4 stock



EDGE,S&B,SCT,PHP Hydra,TS-Perf,OEM parts,Sam Wyse trans,VB's,LED's,MBRP,ISSPRO,ICON,FOX,KC TURBOs,SD 7.3 fuel kits, HPOP lines

www.cncfab.us or email sales@cncfab.us

Corey@CNCFAB is online now  
post #3 of 3 Old 02-23-2014, 12:33 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2013
Location: McGuire AFB, NJ
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Update on this issue. So I had the truck running a little bit before I replaced the pump, ran fine. I got my tax return and decided to just replace the whole pump, so that came in and I replaced it, all went well, filled it and went to start the truck, it cranked, fired up, ran for a minute then died. After that, it cranks fine (except for when I kill the batteries from cranking it) but wont fire at all. Had a friend over to look at it, he checked the HPOP Res level and the oil rail levels, topped them off and said it looked like I might have a little air in there. He tried to bleed them, to no avail, then I had to close up shop to run errands. Haven't looked at it since 2 days ago, went to crank today, still just cranking no firing. I'm just completely stumped now. Not sure what to do, tired of seeing it sit in my driveway. Anyway, hoping you guys have some suggestions or ideas as to why its not starting. Fuel pressure is fine, pulled the filter and its getting plenty of fuel in there. I'm not seeing any smoke out my tailpipe when cranking though which leads me to believe its not burning any fuel. I'm just frustrated and want to get it running again. Thanks

2001 F350 XLT 7.3 Powerstroke SRW Crew Cab 4x4. "Straight Pipe" Exhaust, High Idle Mod
msimpson619 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome