no steering or brakes - Ford Powerstroke Diesel Forum
Suspension & Steering Discuss OEM & aftermarket suspension, lifts, air ride suspension, shocks, steering components, etc.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2012, 02:01 AM
Member
 

Join Date: Mar 2012
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no steering or brakes

Pulling out of driveway this morning and got a mile down road and truck lost all power steering and had no brake power hardly. I have a 2005 6.0 PSD. It just had a new Ford power steering pump but on about a week ago. The truck has 6 inch lift with 37 tires. I'm thinking that its got something to do with hydroboost but not positive. I can not see any visible leaks as of now its still dark out so any thoughts would help. I would like to try and fix myself
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-25-2012, 07:56 AM
Powerstroke.org Fanatic
 

Join Date: Mar 2012
Posts: 145
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Are you sure that your serpitine belt didd'nt break off?
Reply With Quote Quick reply to this message
  #3  
Old 05-25-2012, 08:07 AM
Compression Ignition Addict
 

Join Date: Oct 2009
Posts: 786
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I had this problem with my 00 7.3. I was at QT and my high pressure power steeting hose (brake manifold to power steering pump) busted and left a mess. That made my steering and brakes go out. I know you say you cant see any leaks but check that out. It was a fairly easy fix. $60 and a couple hours and a couple beers.

Reply With Quote Quick reply to this message
  #4  
Old 05-25-2012, 04:37 PM
Member
 

Join Date: Mar 2012
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
checked belt and all lines i could didnt find anything. had it towed to shop who put th ps pump on and ended up to be that the pump he had just put on went out already. lol. so if was still under warranty no $$$ out of my pocket
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:12 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors