Front end rattle in turns - Ford Powerstroke Diesel Forum

Suspension & Steering Discuss OEM & aftermarket suspension, lifts, air ride suspension, shocks, steering components, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-13-2012, 03:16 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Front end rattle in turns

I have a 2005 F250 PSD 4x4 and today i was driving along and went into a turn and suddenly the truck started shaking like the wheels were going to rattle off. This continued all the way home. When I got home it was dark so I didnt climb under it.

Does anyone have any ideas on what might be the issue? I hate to ask without knowing much but I have a broken ankle and need the truck sunday night to go to work so i need to figure out kind of quickly what might be wrong with it and what i should look at.

I would greatly appreciate any help I can get!
--JP-- is offline  
post #2 of 4 Old 01-15-2012, 04:20 PM
Compression Ignition Addict
 
shadowe123's Avatar
 
Join Date: Sep 2007
Location: Austin tx
Posts: 337
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
How hard is the shake? Check the track bar make sure everything is tight.



AFE stage 1 intake
straight pipe
6 inch lift with 37/13.50r20 toyo mts
alpine iva-w200 screen with jl xr in the doors and 2 12" jl w1 behind seat
autometer phantom 2 gauges
DP TUNER 60 tow, 80 eco, and 140 SMOKE yea i love it

DirtAssassins Clothing
shadowe123 is offline  
post #3 of 4 Old 01-15-2012, 06:31 PM
Compression Ignition Addict
 
Tj Krawler's Avatar
 
Join Date: May 2010
Location: Western New York
Posts: 958
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Any noise while it shakes? Did it just start happening or slowly get worse? When was the last time you used 4x4? I had a issue come up where the front end would shake and clunk/pop turning turns. Had a hub that didn't unlock. (Both hubs were in auto) Put it in 4x4 and take it back out. It fixed it self before I had time to test anything. You can check for it by jacking up the front end and try turning each tire.

Alan
2000 F-350 CC LB DRW 4x4 XLT Auto

- Intake
- Exhust
- ScanGauge
Tj Krawler is offline  
post #4 of 4 Old 01-18-2012, 12:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the input guys. The problem ended up resolving its self but I am thinking it was possibly a bubble in the power steering because when the light came out and I looked around a little bit I found that the fluid was a little low. Since then I have topped it off and driven a few hundred miles and it hasnt come back!

Is it possible that it popped into 4x4 even if i have manual hubs?
--JP-- is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome