Death wobble after changing shocks! - Ford Powerstroke Diesel Forum
Suspension & Steering Discuss OEM & aftermarket suspension, lifts, air ride suspension, shocks, steering components, etc.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2010, 10:02 AM
Powerstroke.org Rookie
 

Join Date: Oct 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Death wobble after changing shocks!

Well, i have a 2006 F-250 4x4 with a 6" Fabtech lift. I changed out the original Fabtech shocks for Ranchos. The Fabtechs were leaking and they had about 55000 miles on them. This set off a death wobble on every bump i hit at 65mph. I changed out both of my fabtech stabilizers, had a new adj Track Bar installed, and replaced the drag link and right tie rod end. They also did an alignment of course. It is better, but i continue to have the death wobble and am scared to put the kid and wife in it. Does anyone have any ideas? I do have new Fabtech shocks coming this week, as the Ranchos seem to have been the original culprit. Any Ideas are greatly appreciated!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-03-2010, 11:08 AM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: Wellington Nevada
Posts: 8,533
Thanks: 1
Thanked 27 Times in 27 Posts
Feedback Score: 5 reviews
Do you have adj 4 link arms..maybe they set to stock Castor where it should be set to 2x's
They maynot have tightened the track bar correctly
Rancho's..cheap shocks but shouldn't make it wobble.
Reply With Quote Quick reply to this message
  #3  
Old 11-03-2010, 12:24 PM
Powerstroke.org Rookie
 

Join Date: Oct 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well i think my arms are adjustable, however all i did was change shocks and this wobble started. I did not have anything aligned until later on. I had not ever felt anything like this the first 30,000 miles. This has been very puzzling. I am thinking of removing the ball joint track bar mount, and installing a new one on top of where the stock mount is to better align the track bar and drag link. Has anyone done this before?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors