Steering Problems with Trailer - Ford Powerstroke Diesel Forum
Suspension & Steering Discuss OEM & aftermarket suspension, lifts, air ride suspension, shocks, steering components, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-20-2010, 04:44 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Steering Problems with Trailer

I have an '02 f250 powerstroke, single axle, crew cab, 8'bed. I have 2 different trailers I pull with this truck. I have a problem with the power steering while attached to the trailers. It's almost like the power steering is gone at certain points and I really have to crank to get the weehls to turn. Took it to a local dealer and the lubed the fron end and said they couldn't find any problems with the gear box nor power steering.

A friend talked to someone and told him there may be a power(electrical) issue with the signal going to the power steering with a trailer attached. Said it may be cutting the power and causing pump malfunction.

Anyone ever had this or hear of similar problems? If so, any fix? I neeed help because this is a real PITA. Thanks bunch in advance for thoughts/ideas.
NCBBQ is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-20-2010, 08:46 AM
Powerstroke.org Fanatic
 
Join Date: Apr 2009
Posts: 147
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mechanical linkage from steering wheel to steering gear box, so electrical shouldn't be it.

1999 F250 4x4 with 2004 Cummins backed by a BTS transmission, '06 axles suspension, 4.5" lift, smoothed/painted frame, FASS 150/150, Hellmann Performance Fuel Sump, ARP head studs.
Pics:
http://www.flickr.com/photos/48741690@N08/
Aggie007 is offline  
post #3 of 3 Old 04-22-2010, 05:08 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've been told to look into the power steering pump as there is some sort of an electrical assist that the trailers may be pulling from causing the issue. I'm grabbing at straws here.
NCBBQ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome