problem with my 7.3 - Ford Powerstroke Diesel Forum
Sooner Powerstrokers Oklahoma Chapter Area

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-10-2009, 05:34 PM Thread Starter Rookie
shackdezy's Avatar
Join Date: May 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question problem with my 7.3

i a 2002 f250 when its idling it runs rough and smokes white with a little blue but when im driving it does not smoke or run rough only at idle and it doesn't always idle rough or smoke its just off and on it does it. Some people are telling me a injector can be fouled out.
shackdezy is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome