7.3l idi questions need answer! - Ford Powerstroke Diesel Forum

Powerstroke.org Site Problems Let us know if you are having any site issues here!!

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-09-2012, 08:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3l idi questions need answer!

Hello friends,
I have a few questions! First of all I have a 1993 ford f-250 ext cab 7.3l idi. First, I have to use starting fluid to start the truck. Once the truck is started it smokes alot of blue smoke out of exhaust regardless if warm also does it when driving as well. When I purchased the truck it had a electric fuel pump on the frame rail connected to fuel lines but still has the factory pump intacted in place. Don't quite understand why and if electric fuel pump is allowing diesel fuel to run back to tank not allowing it to start. I also thought maybe factory pump may work and sending to much fuel making it smoke alot not for sure. Another thought why it won't start could be low compression. I don't know but its aggrevating. It has a new injection pump on it. Maybe injectors might be bad. Don't know let me know thanks Andrew
pullingdiesel is offline  
post #2 of 3 Old 11-09-2012, 09:12 PM
Compression Ignition Addict
 
700xxmaniac's Avatar
 
Join Date: Aug 2011
Location: middleburgh, n.y
Posts: 449
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
You ever try to replace ur glow plugs and the relay


Sent from my Autoguide iPhone app

99 ford f-250 crew cab powerstroke
-skyjacker 6'' lift
- 395-70r-16 mickey tomson baja mtz
-sct tune
-stright pipe (vrrrooom)
-cops are in love with the thing

08 TRX700XX
-uni
-primary drive 13t
-pclll
-cp 11:1

01 recon es 250
-kenda 22'' bear claw
-53mph top speed

700xxmaniac is offline  
post #3 of 3 Old 11-09-2012, 09:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
YES BOTH HAVE BEEN REPLACED AND EVEN THE INJECTION LINE KIT AS WELL. NO LEAKING FROM INJECTION LINE KIT
pullingdiesel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome