Any CB Guru's? - Ford Powerstroke Diesel Forum
Off-Topic Discussion of All Non-Related Topics

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-27-2008, 08:20 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 31 Times in 22 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Any CB Guru's?

Probably a long shot since this a truck forum but figured I'd ask anyway.
One of my buddies hooked me up with a RCI-2950 that he wasn't using anymore. It worked fine when he pulled it from his truck a few years ago but I put it in my rig and have NO squelch at all. I thought the speaker had gone out so I bought an external and still no go. I got a brand new magnet mount antenna as well so I'm literally baffled as to why I get no sound.
Anyone have any thoughts as to what I could check?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-27-2008, 08:23 AM
Rice Hunter
 

Join Date: Aug 2007
Location: Norfolk,VA...Near the beach
Posts: 4,036
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Haven't had one since the early 80's.
I used to have a blast with it. Still remember my handle and call numbers lol
Reply With Quote Quick reply to this message
  #3  
Old 04-27-2008, 08:27 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 31 Times in 22 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Quote:
Originally Posted by Diesel Freak View Post
Haven't had one since the early 80's.
I used to have a blast with it. Still remember my handle and call numbers lol

I haven't run one in a long time myself and I used to be REALLY big into them. I'm spending a lot of time on the road these days so figured I'd start back up again. If I can get this damn thing to work.
Reply With Quote Quick reply to this message
  #4  
Old 04-27-2008, 08:30 AM
Serving Our Country!
 

Join Date: Jul 2007
Location: Tucson
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to AMMO22
Hey RS, check out sparkyscbshack.com and see if there is any useful info on there.
Reply With Quote Quick reply to this message
  #5  
Old 04-27-2008, 08:50 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 31 Times in 22 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Cool- Brett, I'll check it out. THANKS!
Reply With Quote Quick reply to this message
  #6  
Old 04-27-2008, 09:28 AM
KVFD
 

Join Date: Nov 2007
Location: Kearney, Nebraska
Posts: 4,061
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to redstroker_2002
do you have the co axe plugged in? Check your swr's and make sure they are about 3/4 on and also check your rf gain and turn it up all the way and see if that helps
Reply With Quote Quick reply to this message
  #7  
Old 04-27-2008, 09:36 AM
Banned

 

Join Date: Jan 2008
Location: Belle Chasse
Posts: 3,445
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
SWR's should be around 1.2 -1.3,...for optimal performance.
Reply With Quote Quick reply to this message
  #8  
Old 04-27-2008, 10:10 AM
Compression Ignition Addict
 

Join Date: Aug 2006
Location: Vernon, Texas
Posts: 3,333
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slammedSI Send a message via MSN to slammedSI Send a message via Yahoo to slammedSI
hey Alan i have the same thing going on with mine. Got so frustrated with it i just gave up, cuz i couldnt find anyinfo on it to help me out. If you happen to find out whats wrong with yours let me know.
Reply With Quote Quick reply to this message
  #9  
Old 04-27-2008, 11:03 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: San Marcos, Texas
Posts: 446
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check out RadioActiveRadios.com - CB Radios, 10-Meter Radios, Base Stations, Antennas, and more!

Give him a call or shoot him an email. He really knows his stuff. I got my Connex 3300HP from him, and its the best radio Ive ever used!
Reply With Quote Quick reply to this message
  #10  
Old 04-27-2008, 01:43 PM
Banned

 

Join Date: Jan 2008
Location: Belle Chasse
Posts: 3,445
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Alot of people think CB's are "plug and play" they definitely aren't.....sometimes you could get lucky....but most times, it takes some tweeking to get them to work correctly.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors