Glow Plug System Saver - Ford Powerstroke Diesel Forum
Non-Powerstroke General Discussion General Discussion for 6.9L and 7.3L IDI (Non-Powerstroke) Engines

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-21-2008, 06:28 AM
Emergency Services
 

Join Date: Oct 2007
Location: Littleton, Co
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Bamfster
Glow Plug System Saver

I have heard of something that is added to the GP system that disables the relay/GPs whenever the engineblock temp is above 120 deg. Anyone have more info on this? I googled it and came up one site (us diesel perf.) but they had very limited info on it. My 7.3 IDI on average kills 2 GPs every 9 months. Yes I'm using Motorcraft parts. Let me know if anyone has info...thanks guys
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-21-2008, 06:30 AM
Premium Member
 

Join Date: Jan 2006
Location: florida
Posts: 1,893
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i would try to track down the prob on why your losing glowplugs. they should last alot longer than that.
Reply With Quote Quick reply to this message
  #3  
Old 01-21-2008, 06:34 AM
assistant director

 

Join Date: Feb 2007
Location: Springfield, TN
Posts: 1,052
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have only put on one gp relay on my 96 about 5 years ago it was burnt no problems since
Reply With Quote Quick reply to this message
  #4  
Old 01-21-2008, 06:43 AM
Emergency Services
 

Join Date: Oct 2007
Location: Littleton, Co
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Bamfster
GP system (relay/plugs/wiring/ect) all check fine, not only by me but also a diesel shop. Once the temps drop the truck gets hard to start, every winter. Sure enough I check the GP system and I'll have 1-2 dead GPs...never the same one(s) twice. Replace the dead plugs and viola, truck will start perfectly no matter how cold it gets, even without the block heater plugged in. The guy at the shop told me about this GP saver that disables the GP system when it is not needed so it saves all the components from undue wear and tear.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors