No Power Power Won't Start - Ford Powerstroke Diesel Forum
Non-Powerstroke General Discussion General Discussion for 6.9L and 7.3L IDI (Non-Powerstroke) Engines

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-25-2012, 03:30 PM
Member
 

Join Date: Mar 2010
Location: Glendale
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No Power Power Won't Start

This may seem like a stupid question but I am stuck on this.

I went to start my truck yesterday and the radio went on then off a few times while i was waiting for the glow plugs so i powered it off. Went to start it and i heard the starter fire the motor barely turned then it was dead. So i charged it up and even hooked up my jeep to jump it. Got nothing. Now I have no cab lights no radio. No starter. Nothing works. I checked and the batteries have 12.7 volts and are a month old. The fender solinoid has pawer to all three terminals. and the starter constant has .2 volts. I checked the starter wire and got 12.7 volts 20 the 90 degree bend at the block and that was it. Just .2 volts after that. 12.7 going to the glow plug relay.

Any ideas? Starter, solenoid? Wire? Not sure the diagnosis steps here.

Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-25-2012, 03:36 PM
Compression Ignition Addict
 

Join Date: Dec 2012
Location: COLLEGE STATION
Posts: 439
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have some body turn the key while you are checking for voltage at the starter solenoid if no voltage maybe the ignition switch ? you can get a book on these trucks at the auto parts stores that would give you more info on the electrical circuitry
Reply With Quote Quick reply to this message
  #3  
Old 12-25-2012, 07:07 PM
Member
 

Join Date: Mar 2010
Location: Glendale
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I still have no power at the starter when I turn the key but I would imagine if it was the ignition the lights would still work.
Reply With Quote Quick reply to this message
  #4  
Old 02-19-2013, 02:16 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
clean terminals thoroughly. If they are bad, replace
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:13 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors