stalling problem - Ford Powerstroke Diesel Forum
Non-Powerstroke General Discussion General Discussion for 6.9L and 7.3L IDI (Non-Powerstroke) Engines

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-26-2012, 11:32 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Location: middleburg,fl
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
stalling problem

ok i am getting a 86 f350 with a 7.3 turbo(banks sidewinder). it has a problem of stalling. it sounds like its skippy at idle. when you give it some throttle it sounds bogged down. it will stall out and wont start back up for about an hour. any ideas on where to look. po said he had the #4 injector replaced and it had build up on the bottom of it and he thinks it got on the piston and ruined the rings... it does smoke some at idle and alot when you rev it up.will bad rings cause this? or is there another problem?

'08 f250 supercab 2wd lwb 6.4 turbo diesel daily driver
'92 explorer 4x4 my toy
4x4troy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-28-2012, 06:04 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Location: middleburg,fl
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
changed the fuel filter and it does start alittle better...but now it shuts down after about 10 secs and just before shut down it tires to idle up then chocks out...no stumble just shut off no hesitation. but it will start back up after about 5 trys not like before about an hour later....so making some progress.

'08 f250 supercab 2wd lwb 6.4 turbo diesel daily driver
'92 explorer 4x4 my toy
4x4troy is offline  
post #3 of 3 Old 08-29-2012, 12:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Location: middleburg,fl
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
its running really good now. i removed the reg. but the biggest problem was the injector po had put in....it was finger tight...i tightened it down and she fires right up...smoked for awhile but smoke is gone and i just drove it about 10 miles and was good. turbo would boost to 10 psi but it just did not feel impressive....kinda like a older 4cyl.auto car with a bad tune up...lol fcdp said that it looks like the ip is advance one notch...should i go back to stock and turn up the pump one flat? it is a turbo...banks sidewinder on a 7.3.

'08 f250 supercab 2wd lwb 6.4 turbo diesel daily driver
'92 explorer 4x4 my toy
4x4troy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome