?s for 86 - Ford Powerstroke Diesel Forum
Non-Powerstroke General Discussion General Discussion for 6.9L and 7.3L IDI (Non-Powerstroke) Engines

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-03-2007, 06:25 PM Thread Starter
Powerstroke.org Rookie
 
montecarloman's Avatar
 
Join Date: Apr 2007
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
?s for 86

my friend has 86 ford 4speed 2wd duelly. and the truck has after market turbo and he put all new injectors. but the problem is the it dont chage right we just put new alt on it wires r hooked up right but still didnt charge we found a box unpluged its on the iner fender on right side pluged it back in and still no charge. this little box looks what is it. it looks like the same box that old 80s dodges had on the fire wall. i know that the little box on the fire had to do something with dodges. is the same on the fords ?????? thanks
montecarloman is offline  
post #2 of 3 Old 09-03-2007, 06:28 PM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It is probably the voltage regulator. It should have four or five wires going to it.

Derrick

My photobucket




'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips, 4" DIY intake w/ AEM filter, Wicked Wheel 2, 360 thrust bearing, Homemade E-fuel conversion, Wildman Chip, 160cc DIY injectors , DIY IDM mod) 230K and counting...
pipelayerjdh is offline  
post #3 of 3 Old 09-03-2007, 06:45 PM Thread Starter
Powerstroke.org Rookie
 
montecarloman's Avatar
 
Join Date: Apr 2007
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i see now that would be on the drive side of the truck and theres two of them right and they look the same now what am i looking for damge wise how i know if its broken
montecarloman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome