Factory Turbo - Ford Powerstroke Diesel Forum
Non-Powerstroke General Discussion General Discussion for 6.9L and 7.3L IDI (Non-Powerstroke) Engines

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-31-2010, 08:54 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Factory Turbo

Hello,
Is there any way to tell if the turbo is working on my1994 Ford model 350 with 7.3L IDI? If so how to go about it.
Thanks in advance
Felix B
katman104 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-31-2010, 07:39 PM
Compression Ignition Addict
 
dakotajeep's Avatar
 
Join Date: May 2010
Location: Bismarck, ND/Ft Riley, KS
Posts: 248
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Install a boost gauge.....

Thad


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2003 F350 6.0 4x4 Crewcab Longbed SRW w/X Code Front Springs- 265/75R16's on it now. Still got the 285 retreads in the shed though.
Future modifications: Edge Insight CS, SCT X3 with Custom Tunes

-SOLD-
1994 F350 7.3 Banks Turbo IDI 4x4 Crewcab Longbed-Miss you old girl
dakotajeep is offline  
post #3 of 7 Old 08-01-2010, 07:34 AM
Compression Ignition Addict
 
FordGuy100's Avatar
 
Join Date: Jun 2008
Location: Silverton, OR
Posts: 2,492
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Yup. Boost gauge is the best way.

-Justin-
1985 Ford F-250 with a 6.9 IDI/T-19 4speed 4x4
Paint, Eagle Alloys, Kelly Safari TSR's, ATS turbo, gauges

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 Jetta TDI 5 speed
2004 2wd Excursion Limited 6.0. Testing how loyal I am to Ford
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1997 Passat B4V TDI. 1 of 80 imported in 97. 50 MPG and a factory 25 gallon fuel tank!
FordGuy100 is offline  
post #4 of 7 Old 08-02-2010, 06:42 AM
Compression Ignition Addict
 
powerstrokes only's Avatar
 
Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You should be able to feel it. I think it would be pretty gut less if it is not building any boost, do you see any oil leaking from the turbo anywhere? I think this turbo is pretty tough, mine has 312,000 miles and pulls like a freight train, it pulls within 10 mph of my 6.4 with a programmer and DPF delete!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fletcher
'90 F250 Supercab IDI 7.3
Banks Sidewinder Turbo
4'' straight pipe
116,000 miles

'94 F250 single cab IDI Factory Turbo 7.3
3'' banks down pipe
Banks pyrometer
3 1/2'' straight pipe
K&N Air filter
Hypermax air intake
Hydrogen Generator
Pump turned up
Timing advanced
315,000 miles!



'89 F250 4x4 supercab 7.3 IDI
4'' exhaust
pump turned way up!!!
297,000 miles
powerstrokes only is offline  
post #5 of 7 Old 08-02-2010, 11:01 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No oil leaks just seems not to have much top end speed.65MPH up a gradual grade. mine has a 122,000 on it. it does not miss or anything.Just seems not to have the power it used to. Changed fuel filter and was wondering if there was a way to tell if turbo is working under load at 60mph.
katman104 is offline  
post #6 of 7 Old 08-02-2010, 06:47 PM
Compression Ignition Addict
 
dakotajeep's Avatar
 
Join Date: May 2010
Location: Bismarck, ND/Ft Riley, KS
Posts: 248
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
If you are going up a grade with an IDI at 65mph the turbo is most likely working. I had troubles going up hills in my rig without a turbo....

Thad


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2003 F350 6.0 4x4 Crewcab Longbed SRW w/X Code Front Springs- 265/75R16's on it now. Still got the 285 retreads in the shed though.
Future modifications: Edge Insight CS, SCT X3 with Custom Tunes

-SOLD-
1994 F350 7.3 Banks Turbo IDI 4x4 Crewcab Longbed-Miss you old girl
dakotajeep is offline  
post #7 of 7 Old 08-03-2010, 11:43 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks to all for the information.
Felix B
katman104 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome