99 7.3L Running Rough - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-07-2011, 09:39 PM Thread Starter
Powerstroke.org Fanatic
 
Chuck6669's Avatar
 
Join Date: Feb 2011
Location: Baker, Mt
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 99 7.3L Running Rough

Hi, I'm brand spanking new to the forum. I recently had an issue with my 99 7.3l F250 running rough. I ran the diagnostics on it and it showed a P1316 trouble code. I took it to the diesel performance center and told them that I ran the diagnostics on it and came with a P1316 trouble code. I thought that it might be the UVC wire harness coming loose again. Anyway that afternoon they call and say that the #7 injector is bad and the valve cover gasket need to be replaced. I told them if the injector is bad and needs to be replaced that it is ok to replace it.

That evening they called and said my truck was done and ready to be picked up, they said the problem was the valve cover gasket. My question to anyone on here is how in the world can a valve cover gasket make the engine run so rough. And for the diagnostics to show a P1316 trouble code indicating that the ICM circuit has problems? The truck runs great now, I am perplexed about this issue. So if anyone would take the time to help me understand how a bad valve cover gasket would cause the engine to run rough I would greatly appreciate it.
Chuck6669 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-07-2011, 09:44 PM
Mod Newbie

 
dhanna6powerstroke's Avatar
 
Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 13,130
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 6
Thanked 141 Times in 133 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Chuck6669 View Post
Hi, I'm brand spanking new to the forum. I recently had an issue with my 99 7.3l F250 running rough. I ran the diagnostics on it and it showed a P1316 trouble code. I took it to the diesel performance center and told them that I ran the diagnostics on it and came with a P1316 trouble code. I thought that it might be the UVC wire harness coming loose again. Anyway that afternoon they call and say that the #7 injector is bad and the valve cover gasket need to be replaced. I told them if the injector is bad and needs to be replaced that it is ok to replace it.

That evening they called and said my truck was done and ready to be picked up, they said the problem was the valve cover gasket. My question to anyone on here is how in the world can a valve cover gasket make the engine run so rough. And for the diagnostics to show a P1316 trouble code indicating that the ICM circuit has problems? The truck runs great now, I am perplexed about this issue. So if anyone would take the time to help me understand how a bad valve cover gasket would cause the engine to run rough I would greatly appreciate it.
The valve cover gasket on the 7.3 has the connector built into it. The harness plugs into the valve cover gasket and then you have the harnesses under the valve cover that go to your injectors and glow plugs.
Click link and you can see what I'm talking about
http://k-mansparts.com/items/super-d...584-detail.htm

dhanna6powerstroke is offline  
post #3 of 3 Old 02-07-2011, 09:55 PM Thread Starter
Powerstroke.org Fanatic
 
Chuck6669's Avatar
 
Join Date: Feb 2011
Location: Baker, Mt
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, I didnt know the harness and gasket were connected together. Simple enough explanation. If this happens again I will be sure to do the job myself next time instead of paying a mechanic $$. I have had issues with the wire harnesses coming loose before. I guess with 196k miles things kind of vibrate loose.
Chuck6669 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome