Ford Powerstroke Diesel Forum - View Profile: bismic

bismic bismic is offline

Compression Ignition Addict

  Visitor Messages

Showing Visitor Messages 1 to 9 of 9
  1. Patriot
    03-19-2017 06:41 PM - permalink
    Patriot
    I tried to say you're welcome in PM but your PM inbox is full and won't accept any more.
  2. Patriot
    02-17-2017 07:40 PM - permalink
    Patriot
    I started on this site when you were a frequent poster. I've learned more from you than all these guys put together.
  3. chorbaa92
    01-14-2014 06:17 PM - permalink
    chorbaa92
    Soon to be 6.0 owner... Still have them spreadsheets everyone's talking about? Chorbaa92@gmail.com
  4. bucky1963
    03-19-2012 07:28 AM - permalink
    bucky1963
    Truck started and ran for a few seconds 3-4 times and now I have no start and no pressure on the icp any suggestions would be greatly appreciated.
  5. 05 Pstroker
    02-09-2012 08:20 AM - permalink
    05 Pstroker
    I have driven trucks for 32 yrs., including half ton , 3/4 ton and 1 ton, and have yet to get over 42K out of them. What tires did you get 85K out of them? If you don't mind me asking. Thanks, Tracy.
  6. Lilpooh
    01-04-2012 03:44 PM - permalink
    Lilpooh
    There were two threads.
    http://www.powerstroke.org/forum/gen...er-update.html

    http://www.powerstroke.org/forum/gen...-impeller.html


    I've data logged 4 times with the stock pump and 4 times with BPD waterpump. When I compared the ECT before and after the BPD, 3 out of the 4 readings with the BPD showed the ECT was reaching operating temp faster with in the first 6 minutes of driving. I have put the AE data log into a spreadsheet, just need to figure out how to get it onto the forums for others to see. IIRC, the delta between the stock and BPD ECT with in the first 6 minutes was 20*ish to 40*ish.
  7. steventothemax
    12-23-2011 08:00 AM - permalink
    steventothemax
    would love the scans for the fuel pump install. Installed fuel gauge and got 40psi sitting in my driveway. Already have the blue spring upgrade to I'm confident this is my issue.
  8. buf4rd22
    04-17-2010 06:22 PM - permalink
    buf4rd22
    hi, I did a scan, i cleaned the egr and there is no anti freeze in the erg port, i also disconnected the icp and it still would not start.with it conected it will at least pop off. I have 47v reading for the ficm the icp pressure is 10800 while cranking. inj,pressure reg shows 46 psi. the codes i have im sure were caused from cranking it so much they were low voltage codes for icp and ficm with charger on is when i got the ficm reading for 47 volt. im lost now on what to check. you can hear little or no noise when you do a buzz test. could i have bad relays? cam or crank sensors or pcm thank you for any help you can give me
  9. buf4rd22
    04-17-2010 10:03 AM - permalink
    buf4rd22
    Hi i read your posts i like them buti have a problem with no start mine will crank and wont start. i cant hear the buzz test what would cause this? if you could help thank you. Jeff

  About Me

  • About bismic
    State/Province
    Texas
    Ride
    2006 6.0L PSD FX4
    Engine
    6.0 factory turbocharged
    Cab Configuration
    Crew Cab Short Box
    Drivetrain
    Single Rear Wheel 4X4
    Tranny type
    Torqshift
    Tires
    Street Radials
    Horsepower
    0.0
    1/8 Mile ET
    0.000
    1/8 Mile MPH
    0.00
    1/4 Mile ET
    0.000
    1/4 Mile MPH
    0.00
  • Signature
    Mark
    06 F250CC SB FX4 Lariat;ARP studs;OEM gaskets; Banks exhaust;DynaTrac Ball joints;Coolant filter; High-Idle;RACCCV6000;JimmiJammers;Ravelco;SynchroMax trans case;Fumoto valves;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270AXP;PowerInverter;Rancho7000's; BPD EGR cooler;One-piece HPOP fitting;BilletWaterPump;SCT w/ Matts SRL;ELC Ultra

  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: Today 04:02 AM
  • Join Date: 04-05-2007
  • Referrals: 3

  Friends

Showing Friends 1 to 1 of 1
  • buf4rd22
    • buf4rd22 is offline

  Mentions

04-16-2017
08:19 PM - Rattlesnake18 mentioned bismic in post New transmission to hot.
...help with things... bismic
04-04-2017
05:13 AM - G8orFord mentioned bismic in post Odd Whistle coming off throttle
...85 toren302 kaya bismic junior125 ZMANN H...
03-31-2017
08:41 AM - djmaguire mentioned bismic in post Torque PRO APP exactly which PIDS??
...set. You can thank bismic for this. I don't h...
03-10-2017
06:32 PM - G8orFord mentioned bismic in post New 6.0 owner
...too much about what bismic said. He's just tel...
02-17-2017
04:24 PM - Patriot mentioned bismic in post I LOVE POWERSTROKE.ORG
Let's not forget bismic. And the guy who hel...
01-03-2017
08:01 AM - G8orFord mentioned bismic in post Odd Whistle coming off throttle
...a that I found from bismic on FTE to convert IC...
11-26-2016
04:35 AM - G8orFord mentioned bismic in post Torque Pro PID question
...sed on the info by bismic and the numbers look...
11-25-2016
01:14 PM - G8orFord mentioned bismic in post Torque Pro PID question
...nce to a thread by bismic on FTE where he and ...
08-30-2016
05:23 AM - G8orFord mentioned bismic in post cranks fine warm or cold idles foe a while then misses
..., where's Lilpooh & bismic been anyway). I kno...
11-25-2015
05:01 PM - G8orFord mentioned bismic in post 6.0 No Start Stumped
^^ bismic touched on it but Da...

  Quotes

04-24-2017
04:18 AM - juleshockey6 quoted bismic in post bad fuel pump?
With the key off, you can c...
04-18-2017
05:50 PM - bismic quoted desertranger in post ECT/EOL TEMP DELTAS
I don't think I want to spend $40...
04-14-2017
07:37 AM - harlo quoted bismic in post Odd transmission issue. Solenoid?
It would be very helpful to...
04-12-2017
01:52 PM - D-L quoted bismic in post low pressure oil pump failing.
I have heard people over th...
04-10-2017
05:46 AM - G8orFord quoted bismic in post Water Pump Replacement
The BPD water pumps were in...
04-04-2017
07:35 PM - kaya quoted bismic in post 2007 STC
Response from Ford Doctor: ...
04-03-2017
07:18 PM - kaya quoted bismic in post 2007 STC
no, none came with it. M...
03-27-2017
03:01 PM - D_L quoted bismic in post low pressure oil pump failing.
I have heard that often tim...
08:05 AM - bismic quoted DMc in post Fix your old 6.0 or go for new?
Sounds like you're in th...
03-24-2017
06:29 PM - ZMANN quoted bismic in post Coroded Swiss Cheese Oil Cap
Aluminum doesn't do too wel...
05:39 PM - bismic quoted portcity_gt in post Coroded Swiss Cheese Oil Cap
Pretty common for ford caps to d...
03-21-2017
04:42 PM - bismic quoted hamviper in post Any way to tell which HG is blown?
I can guarantee the cap is fi...
03-16-2017
05:43 AM - Invasivore quoted bismic in post part # for gray vacuum line leading from heater core solenoid (behind dipstick)
It is the full harness, but...
03-14-2017
08:39 PM - kaya quoted bismic in post Advice on several things
Opinions below, ymmv. Also...
03-13-2017
05:45 PM - colo_dually quoted bismic in post Advice on several things
Thanks for all the thoughts...
01:22 PM - bismic quoted BigBoost in post Advice on several things
Opinions below, ymmv. Also m...
03-12-2017
03:23 PM - DMc quoted bismic in post Coolant Filter Controls, help please.
This might help BATTERY....
03:08 PM - bismic quoted mhatlen in post Best battery
I have the Sears Die Hard Pl...
03:03 PM - bismic quoted DMc in post Best battery
Speaking of battery char...
03-10-2017
04:18 PM - jandmsparky quoted bismic in post New 6.0 owner
Even the late 04 has a ques...

  Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0
 
For the best viewing experience please update your browser to Google Chrome