1999 f-350 loss of power - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-28-2014, 08:42 PM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Location: bowling green, ky
Posts: 9
Thanks: 8
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1999 f-350 loss of power

Hey guys i'm new to this forum and to diesels. I just got my first 7.3 about a month ago and I fell in love. But... about a week ago there was just a sudden loss of power. I got home and shut it off for a while started it up and drove it to my mom and dads with no problem. I went to leave and started up the hill and there was no power to climb it. I even put it in low gear. After it stalled 3 times I finally got it up the hill but it stalled 2 more times. I only live about a mile from my parents. After I replaced the UVCH and the glow plugs and GPR changed all the filters and oil it finally goes but still loses power out of no where. I can turn it off and start it back up and its fine for a little while. When it loses the power though it feels like its not getting fuel even though it has 60psi. I looked at the injectors and sleeves and they looked good. The SES light isnt on. And the tach moves when I start it. Its an easy crank too.it has a little white smoke when I first start it but I found out thats normal. When it loses power though it has alot more white smoke and the exhaust sounds weird and the turbo doesnt spool out but it will get to 2,000 rpm's and no more when I hold the pedal to the floor. I checked the HPOP reservoir and its where it's what I would call full (about a half inch from the top from what I could see.) I greatly appreciate any help I can get. Sorry if theres any more threads that are about this. Lol ive been looking for a week and havent found anything like what i'm having trouble with.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2014, 08:32 PM
Super Moderator

 

Join Date: Jul 2008
Location: Orangevale, CA
Posts: 11,539
Thanks: 11
Thanked 101 Times in 95 Posts
Feedback Score: 0 reviews
Glad to have you - to the ORG!!

Take a look in here:
Ford Powerstroke 99-03 7.3L Forums - Ford Powerstroke Diesel Forum
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:48 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors