New from Wisconsin - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-01-2014, 11:30 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2014
Location: South Range , Wi
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New from Wisconsin

REcently bought 95 F350. Had sat for yrs. parts missing from engine. Replaced vac pump, serpentine belt , map sensor, ebp sensor. batteries, tank selector valve, GPR and got it started with no check engine lite. Road tested, it , water in fuel lite came on and it died. Pulled tanks, cleaned , repaired screen , installed water seperator, Drained filter twice, Replaced filter. WIF lite still on but truck starts and runs at idle but will not accelerate until warm . Disconnected what I thought was wire to flapper by turbo. No change , Installed 205 thermostat, no change . Current problems are wif lite on, And no acceleration until warm. Might help to know how this electronic throttle works , Any advise appreciated.
ufdaland is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-01-2014, 10:04 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 14,600
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 140 Post(s)
Thanks: 67
Thanked 406 Times in 391 Posts
Garage
Feedback Score: 0 reviews
Glad to have you - to the ORG!!

One place to check out:
Ford Powerstroke 94-98 7.3L Forums - Ford Powerstroke Diesel Forum


Owner | Operator: Darryl
My Truck: Ol' Guy Garage
Tow Toy: Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #3 of 4 Old 05-01-2014, 10:44 PM
Powerstroke.org Sponsor

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 8,332
Mentioned: 44 Post(s)
Tagged: 0 Thread(s)
Quoted: 150 Post(s)
Thanks: 682
Thanked 405 Times in 370 Posts
Feedback Score: 1 reviews
Welcome to the ORG. I'll be heading up to Eden, WI this coming Tues.

Sent from AutoGuide.com Free App

E99CCLB 250/200s,STG1cam, KC38R, 4" exh,CNC FAB fuel&oil lines,140vIDM,BTS,S&B

97 ECLB F250 4x4 all stock
96 CCLB F350 4x4 D60 swap stock



EDGE,S&B,SCT,PHP Hydra,TS-Perf,OEM parts,Sam Wyse trans,VB's,LED's,MBRP,ISSPRO,ICON,FOX,KC TURBOs,SD 7.3 fuel kits, HPOP lines

www.cncfabricationllc.com or email sales@cncfabricationllc.com

Corey@CNCFAB is offline  
post #4 of 4 Old 05-02-2014, 11:33 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2014
Location: South Range , Wi
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I appreciate this forum, thanks for the replys, here is an update to my throttle problem. [ 95 F350] This morning I removed the pedal assembly to check the idle switch and get a good look at it in general. I checked it with a continuity meter and it seems to be working as it should . [no continuity until activated]. I couldnt see any problem with the wires to either connection so shot some WD 40 on contacts since I didn't have contact cleaner and reassembled. No change. Engine was cold - no response to pedal action. I then tried to drive it . 20 MPH tops. In about 1/2 a mile it started to get alittle better and then slowly came to life. Drove about 10 miles, engine warmed to center of gauge . This is the first time this truck has visited the center of the heat gauge since I have owned it . I wanted to see if once it was warm the problem was gone until the engine cooled. I stopped to fill with fuel , let it idle and when entering traffic lost throttle briefly but got it right back when I kicked the pedal. This could be dangerous in traffic. It still seems temp related but I don't know why or how.
ufdaland is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome