2003 ford f-350 - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-22-2013, 08:02 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2013
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2003 ford f-350

hey guys im new on this and just learning to get on. im hoping to learn from you guys that have experiance on the 6.0.
Allford78 is offline  
post #2 of 5 Old 12-22-2013, 08:18 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,151
Thanks: 82
Thanked 477 Times in 461 Posts
Mentioned: 3 Post(s)
Quoted: 240 Post(s)
Garage
Feedback Score: 0 reviews
Glad to have you - to the ORG!!

A couple of places to check out:
Ford 03-07 6.0L Powerstroke Forums - Ford Powerstroke Diesel Forum

Lone Star Powerstrokes - Ford Powerstroke Diesel Forum - Texas Chapter


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
The Following User Says Thank You to SuperCrutyPS For This Useful Post:
Allford78 (12-22-2013)
post #3 of 5 Old 12-22-2013, 08:42 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2013
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
well i have a 2003 f350 and it was loosing power. i had got it checked out and the 4 and 6 injectors were going. changed 5 of the injectors and now wont start. getting no oil pressure the oil filter housing is not filling up.
Allford78 is offline  
post #4 of 5 Old 12-22-2013, 09:25 PM
Powerstroke.org Fanatic
 
Chilliboy93's Avatar
 
Join Date: Dec 2013
Location: Peoria, IL
Posts: 93
Thanks: 6
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Allford78 View Post
well i have a 2003 f350 and it was loosing power. i had got it checked out and the 4 and 6 injectors were going. changed 5 of the injectors and now wont start. getting no oil pressure the oil filter housing is not filling up.
Did you chane your oil when you did the injectors? If so make sure you have the right oil filter.. If it is the wrong one it will be too long and the filter will restrict the oil from entering the oil bowl..(just dealt with that last night)
Chilliboy93 is offline  
post #5 of 5 Old 12-23-2013, 10:09 AM
Powerstroke.org Sponsor
 
1ATony's Avatar
 
Join Date: Feb 2011
Posts: 2,746
Thanks: 103
Thanked 115 Times in 114 Posts
Mentioned: 27 Post(s)
Quoted: 16 Post(s)
Feedback Score: 0 reviews
welcome to the site

1ATony is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome