Hello from London Canada - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-05-2013, 02:03 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hello from London Canada

Hey guys, I just bought a 2004 f250 last week and love it.... aside from the fact that the 4x4 doesnt work and the back break just seized lol (the dealer is taking care of it). The truck has 49,xxx miles on it and is very clean inside and out. I have wanted a diesel for a long time and I am pumped I finally have one! I want to do some minor mods, I just need to figure out what is best for me for what I will use the truck for.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-05-2013, 09:33 PM
Compression Ignition Addict
 

Join Date: Aug 2011
Posts: 4,859
Thanks: 78
Thanked 54 Times in 52 Posts
Feedback Score: 0 reviews
Reply With Quote Quick reply to this message
  #3  
Old 10-05-2013, 11:34 PM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,845
Thanks: 7
Thanked 34 Times in 24 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
WELCOME!!! Congrats on the rig.

What's up with the 4x4 not working?
Reply With Quote Quick reply to this message
  #4  
Old 10-06-2013, 01:16 AM
Premium Member
 

Join Date: Apr 2013
Posts: 1,632
Thanks: 26
Thanked 59 Times in 59 Posts
Feedback Score: 0 reviews
welcome to the org. I got my first diesel this year too also an 04 and i LOVE my truck
Reply With Quote Quick reply to this message
  #5  
Old 10-06-2013, 04:00 AM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks guys!..... As far as the 4x4, the hubs are tough to turn but will go, once the hubs are engaged it will shift into 4HI but the shifter wont budge into the neutral or 4LO position. I know it needs new hubs, but im not sure if the shifter problem is linkage or something inside the transfer case. I guess I will find out monday or tuesday.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors