New Guy needs help asap - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 35 Old 03-03-2007, 08:53 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New Guy needs help asap

Hello everyone!

This is the first deisel that I have ever owned. It is s 2003 Excursion Limited. Beautiful truck. It is lifted with 37" tires, has an MBRP exhaust, aftermarket intercooler tube, and I just installed a Banks Six Gun with PDA. It is awesome; if only it would keep running. Every 3 or 4 days it starts sputtering around 2000 rpms. If I unhook the batteries for a while and put it back together, it runs great again. I'm confused.

I posted more info in the 6.0 engine problems area. Please take a look at them and see if anyone can help me.

Sorry to start in with my problems right away, but I have been fighting this for months. I am SO happy that I found a place online that may be able to help me get this fixed.

Thanks everyone!
wigs is offline  
post #2 of 35 Old 03-03-2007, 09:01 AM
Compression Ignition Addict
 
slammedSI's Avatar
 
Join Date: Aug 2006
Location: Vernon, Texas
Posts: 3,333
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slammedSI Send a message via MSN to slammedSI Send a message via Yahoo to slammedSI
Quote:
Originally Posted by wigs View Post
Hello everyone!

This is the first deisel that I have ever owned. It is s 2003 Excursion Limited. Beautiful truck. It is lifted with 37" tires, has an MBRP exhaust, aftermarket intercooler tube, and I just installed a Banks Six Gun with PDA. It is awesome; if only it would keep running. Every 3 or 4 days it starts sputtering around 2000 rpms. If I unhook the batteries for a while and put it back together, it runs great again. I'm confused.

I posted more info in the 6.0 engine problems area. Please take a look at them and see if anyone can help me.

Sorry to start in with my problems right away, but I have been fighting this for months. I am SO happy that I found a place online that may be able to help me get this fixed.

Thanks everyone!

Welcome to the site, Its great that you jumped right in! Im sure one of our tecs will be along shortly to help with your problem.

-Bobby Crews- AKA Dr. Cookie Cutter!

2012 Ford F150 Ecoboost
-STOCK-

Quote:
Originally Posted by Dirk View Post
A 7.3 with an edge should never get into a race. Unless it's with a kid on a bicycle.. and the bike has a flat.
slammedSI is offline  
post #3 of 35 Old 03-03-2007, 09:22 AM
Desert Shield/Storm Vet

 
vitalidle's Avatar
 
Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
to Powerstroke.org. Sorry I can't help ya, but there lots of members with the 6.0 that will help ya out!

2002 F-250 4x4 EC, SRW, SB
Auto 93,000 miles
DP Tuner F5
ATS Compressor and 1.0 Exhaust housing high flow back plate
Turbo Back 4" Silverline Exhaust Mbrp Muffler Delete
Isspro Trans,Pyro,Boost Triple Pod
Fumoto Oil Drain Valve
AIH Delete With Boost Fitting

vitalidle is offline  
post #4 of 35 Old 03-03-2007, 09:54 AM
Slacker



 
Evil Eye's Avatar
 
Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 18,231
Mentioned: 7 Post(s)
Tagged: 1 Thread(s)
Quoted: 83 Post(s)
Thanks: 16
Thanked 190 Times in 163 Posts
Feedback Score: 4 reviews
Wigs,
First, to the site. I haven't seen your other post, so you may have more information regarding your rig and what you've tried over there. I'd suggest reloading your stock config back in your ECM and see if it is still having the same problem. Also, when was the last time you changed your fuel filters? You may want to consider that, as well. The experts should be along shortly, but in the meantime, you may want to try those.

Shawn Carlson
EvilEye@powerstroke.org

Proud Navy Vet
2005 F250, CCSB, 6.0 PSD, FX4 (The Sweet Unit is white)
2008 F350, CCLB, 6.4 PSD (Brad-the wife's truck is black)




Engine Mods:
Fluidampr
CCV Reroute (Reinstated)
4" MBRP Exhaust
MTW Stage 1 Turbo
Bulletproof 53V FICM
BulletProof EGR Cooler
BulletProof Water Pump
Riff Raff Intercooler Boots
Gogo Diesel Direct Drive Solenoid
BulletProof All-Aluminum Radiator
BulletProof All-Aluminum Intercooler
BulletProof Oil Cooler System w/ Bypass Filter
SCT w/ Custom Tunes (TSD, DJ's, Innovative, Gearhead, QuickTricks)

Exterior Mods:
Bilstein 5100 Shocks
Icon Adjustable Trac Bar
Firestone RideRite Air Bags
BDS Dual Steering Stabilizer
Aluminum Finned Differential Cover
Reese 16k Manual Slider 5th Wheel Hitch
Icon 2.5" Leveling Kit w/ F-350 rear blocks
20" BMF Novakanes wrapped in 33" Nitto Terra Grapplers
Evil Eye is offline  
post #5 of 35 Old 03-03-2007, 09:54 AM
im fat and ugly


 
stump0331's Avatar
 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,689
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 6 Posts
Feedback Score: 0 reviews
try cleaning the egr valve and see if that fixes it

2004 Excursion
stump0331 is offline  
post #6 of 35 Old 03-03-2007, 10:06 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the input.

It was having the same problem with the stock ECM. I thought that the Banks would fix it, but no luck. I replaced the fuel filter when the problem first happened.

As for cleaning the EGR valve, not sure where that is but I will find it and give it a try.

I am going to repost all of the details in the engine problem section since you did not see it there.

Thank you so much!
wigs is offline  
post #7 of 35 Old 03-03-2007, 10:14 AM
im fat and ugly


 
stump0331's Avatar
 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,689
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 6 Posts
Feedback Score: 0 reviews
ok here ya go, this is a pic of the location of the egr, theres 2 bolts holding it in, unplug it, unscrew those 2 bolts(not sure the size), pull it out it may be a booger to get out since its tight but use yur imagination youll get it. when you get it out it will be more than likely black, covered in soot, use a can of carb cleaner and a tooth brush and clean it till it shines and reinstall

be careful there is a gasket on it, and 2 O-rings on the valve, just dont mess em up while cleaning



2004 Excursion
stump0331 is offline  
post #8 of 35 Old 03-03-2007, 10:20 AM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Welcome to the Forum!

Derrick

My photobucket




'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips, 4" DIY intake w/ AEM filter, Wicked Wheel 2, 360° thrust bearing, Homemade E-fuel conversion, Wildman Chip, 160cc DIY injectors , DIY IDM mod) 230K and counting...
pipelayerjdh is offline  
post #9 of 35 Old 03-03-2007, 10:58 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
perfect picture. I will go try that and report back.

Thanks again.
wigs is offline  
post #10 of 35 Old 03-03-2007, 11:07 AM
im fat and ugly


 
stump0331's Avatar
 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,689
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 6 Posts
Feedback Score: 0 reviews
not a problem, forgot to you to the site

2004 Excursion
stump0331 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome